x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Sequence Save Thumbnail ignoring Tracks on Spawned Actors

When saving a Sequence that contains a Spawned Actor with tracks such as Transform or Attach, they are all ignored when the Thumbnail is captured. Often this leads to missing actors or misplacements in the Thumbnails making them much less useful. Normal behavior is restored if manual Asset Actions/Capture Thumbnail is used.

Here is a tiny DemoBug project.

[link text][1]

  1. Open Project. The only Level will be loaded.

  2. Open the only Sequence. Note the Thumbnails is already wrong. The Pyramid should be on the right as you see in the level, but it is on the left.

  3. Right Click on the Sequence in Content Browser, Asset Actions/Capture Thumbnail. Now it is correct.

  4. Save the Sequence from the Sequencer tab/Toolbar. The Thumbnail is wrong again. The Spawned Pyramid ignores the Transform Track during Save.

Product Version: UE 4.17 Preview
Tags:
bugdemo.zip (20.8 kB)
more ▼

asked Jul 25 '17 at 12:12 PM in Bug Reports

avatar image

Büke
72 1 6 9

avatar image Rudy Q ♦♦ STAFF Jul 25 '17 at 01:24 PM

Hello Büke,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any settings/blueprints/sequences that may be involved?

avatar image Büke Jul 25 '17 at 01:48 PM

Dear Rudy,

There are no Blueprints or subsequences used in the project. Note that the correct behavior is available when manually using Asset Actions/Capture Thumbnail. This has to be reproduced by someone who is familiar with the Sequencer and its Attach feature. I am afraid the engineers of Sequencer, just are not doing these basic tests for some reason.

If it will help I will create an empty project with the bug and send it to you. Please let me know.

avatar image Rudy Q ♦♦ STAFF Jul 25 '17 at 03:17 PM

I would like a more detailed set of steps as I have not been able to reproduce this issue described in your original post with the information provided. I have set up a sequence with an attached actor track and the thumbnail includes both actors (The actor I used for the initial track and the actor in the attach track). After taking a look at the thumbnail that was generated by default I then followed up with the suggested fix (using capture thumbnail). The resulting image for the thumbnail was not changed.

avatar image Büke Jul 25 '17 at 03:32 PM

Thank you for attempting to reproduce the bug. The attachment has to cause a change in world position for it to appear differently in the thumbnail. I have simplified the reproduction and created a BugDemo project. I hope you can see my other replies here.

avatar image Büke Jul 25 '17 at 02:47 PM

Dear Rudy,

I created a tiny project that demonstrates the bugs. The bug is actually more generalized. Spawned Actors ignore all Tracks (not just Attach) during Sequence Save thumbnail captures.

  1. Open Project. The only Level will be loaded.

  2. Open the only Sequence. Note the Thumbnails is already wrong. The Pyramid should be on the right as you see in the level, but it is on the left.

  3. Right Click on the Sequence in Content Browser, Asset Actions/Capture Thumbnail. Now it is correct.

  4. Save the Sequence from the Sequencer tab/Toolbar. The Thumbnail is wrong again. The Spawned Pyramid ignores the Transform Track during Save.

The Close Dirty bug: 5. Close the Sequencer Tab. Even though it was just saved, now it is marked Dirty.

Thank you for testing and reporting that last bug.

I hope this helps.

[link text][1] [1]: /storage/temp/192627-bugdemo.zip

bugdemo.zip (20.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After taking a look at the project provided, I was able to reproduce this issue on our end. I have written up a report and I have submitted to the developers for further consideration. I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: https://issues.unrealengine.com/issue/UE-47693

Make it a great day

more ▼

answered Jul 25 '17 at 04:35 PM

avatar image

Rudy Q ♦♦ STAFF
47.3k 545 132 525

avatar image Büke Jul 25 '17 at 04:39 PM

Thank you! Sorry if this comment will take away the Resolved status. :-)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question