x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android Build Failed - could not find file debug apk

I'm trying to package my game. It fails either for distribution or development. I am able to package the game for so many time and then I just couldn't.

Here is the output log that I get: OutputLog Here is the screenshot for my android SDK and SDK Manager:

alt text alt text alt text alt text

I'm trying to use GameSparks plugin with the OnlineSubsystemFacebook plugins.

Here's what I've tried so far: -Tried reinstalling CodeWorks. Failed. -Tried creating a new project and packaging that. The new project successfully packaged. -Tried migrating assets, plugins, settings, conifg files, enabled GameSparks plugin on edito and OnlineSubystemFacebook on build.cs. Failed.

Can anyone help me? I've been working on this for a week now.

Product Version: UE 4.16
Tags:
001.jpg (31.1 kB)
sdk manager 001.jpg (105.3 kB)
sdk manager 002.jpg (102.5 kB)
sdk manager 003.jpg (104.5 kB)
more ▼

asked Aug 05 '17 at 11:34 AM in C++ Programming

avatar image

zbrtcchr
11 1 4 8

avatar image zbrtcchr Aug 06 '17 at 03:09 AM

Can't anyone help?

avatar image zbrtcchr Aug 07 '17 at 12:51 AM

Okay, I've found when this error is happening.

It's when I add these lines on my DefaultEngine.ini:

 [OnlineSubsystemFacebook]
 bEnabled=true
 ClientId=1375368315904124
 
 [OnlineSubsystemFacebook.OnlineIdentityFacebook]
 MeURL=graph.facebook.com/me?`token
 bUsePopup=true
 
 [OnlineSubsystemFacebook.OnlineSharingFacebook]
 PermissionsURL=graph.facebook.com/me?`token&fields=permission
 
 [OnlineSubsystemFacebook.OnlineFriendsFacebook]
 FriendsUrl=graph.facebook.com/me?`token&fields=friends{`fields}

avatar image OneThatsInspired Sep 25 '17 at 06:48 PM

Hey did you ever get your project to launch. I have the same problem

avatar image zbrtcchr Sep 25 '17 at 07:13 PM

Yeah. I got it working. Are you also trying to use OnlineSubsystemFacebook plugin? The problem is that there is a missing dependency that the FacebookSDK needs. So, I created my own plugin that includes that dependency with the FacebookSDK and that's where I did facebook codes.

avatar image OneThatsInspired Sep 25 '17 at 07:16 PM

ahh i see ok i will do that also

avatar image zbrtcchr Sep 25 '17 at 07:13 PM

I found out the problem when I tried gradle build on 4.17.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question