x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UE Editor 4.17 Mac consistent crash on launch

Unreal 4.17 keeps crushing on project load displaying the following error log:

 FGenericPlatformMisc::RaiseException(unsigned int) Address = 0x108cafc9b (filename not found) [in UE4Editor-Core.dylib]
 FOutputDeviceMacError::Serialize(wchar_t const*, ELogVerbosity::Type, FName const&) Address = 0x108ec725f (filename not found) [in UE4Editor-Core.dylib]
 FOutputDevice::Logf(wchar_t const*, ...) Address = 0x108fad94d (filename not found) [in UE4Editor-Core.dylib]
 FDebug::AssertFailed(char const*, char const*, int, wchar_t const*, ...) Address = 0x108f0081e (filename not found) [in UE4Editor-Core.dylib]
 FMetalRenderPipelineDesc::CreatePipelineStateForBoundShaderState(FMetalBoundShaderState*, FMetalHashedVertexDescriptor const&) const Address = 0x13d1f851a (filename not found) [in UE4Editor-MetalRHI.dylib]
 FMetalBoundShaderState::PrepareToDraw(FMetalHashedVertexDescriptor const&, FMetalRenderPipelineDesc const&) Address = 0x13d1c3c92 (filename not found) [in UE4Editor-MetalRHI.dylib]
 FMetalContext::PrepareToDraw(unsigned int, EMetalIndexType) Address = 0x13d1bda28 (filename not found) [in UE4Editor-MetalRHI.dylib]
 FMetalRHICommandContext::RHIEndDrawPrimitiveUP() Address = 0x13d1a3408 (filename not found) [in UE4Editor-MetalRHI.dylib]
 DrawPrimitiveUP(FRHICommandList&, unsigned int, unsigned int, void const*, unsigned int) Address = 0x11a260db9 (filename not found) [in UE4Editor-Renderer.dylib]
 FProjectedShadowInfo::RenderProjection(FRHICommandListImmediate&, int, FViewInfo const*, bool, bool) const Address = 0x11a9bcef7 (filename not found) [in UE4Editor-Renderer.dylib]
 FSceneRenderer::RenderShadowProjections(FRHICommandListImmediate&, FLightSceneInfo const*, IPooledRenderTarget*, bool, bool) Address = 0x11a9c0cf4 (filename not found) [in UE4Editor-Renderer.dylib]
 FDeferredShadingSceneRenderer::RenderShadowProjections(FRHICommandListImmediate&, FLightSceneInfo const*, IPooledRenderTarget*, bool&) Address = 0x11a9c1396 (filename not found) [in UE4Editor-Renderer.dylib]
 FDeferredShadingSceneRenderer::RenderLights(FRHICommandListImmediate&) Address = 0x11a3bf6c3 (filename not found) [in UE4Editor-Renderer.dylib]
 FDeferredShadingSceneRenderer::Render(FRHICommandListImmediate&) Address = 0x11a26ca11 (filename not found) [in UE4Editor-Renderer.dylib]
 FRendererModule::BeginRenderingViewFamily(FCanvas*, FSceneViewFamily*)::EURCMacro_FDrawSceneCommand::DoTask(ENamedThreads::Type, TRefCountPtr const&) Address = 0x11a8f73d0 (filename not found) [in UE4Editor-Renderer.dylib]
 TGraphTask::ExecuteTask(TArray&, ENamedThreads::Type) Address = 0x11a95b760 (filename not found) [in UE4Editor-Renderer.dylib]
 FNamedTaskThread::ProcessTasksNamedThread(int, bool) Address = 0x108cd31cf (filename not found) [in UE4Editor-Core.dylib]
 FNamedTaskThread::ProcessTasksUntilQuit(int) Address = 0x108cd21d8 (filename not found) [in UE4Editor-Core.dylib]
 FTaskGraphImplementation::ProcessThreadUntilRequestReturn(ENamedThreads::Type) Address = 0x108ccdf61 (filename not found) [in UE4Editor-Core.dylib]
 RenderingThreadMain(FEvent*) Address = 0x10b01ccb1 (filename not found) [in UE4Editor-RenderCore.dylib]
 FRenderingThread::Run() Address = 0x10b0325d7 (filename not found) [in UE4Editor-RenderCore.dylib]
 FRunnableThreadPThread::Run() Address = 0x108d51c90 (filename not found) [in UE4Editor-Core.dylib]
 FRunnableThreadPThread::_ThreadProc(void*) Address = 0x108cf3b80 (filename not found) [in UE4Editor-Core.dylib]
 _pthread_body Address = 0x7fffeb7ce93b (filename not found) [in libsystem_pthread.dylib]
 _pthread_body Address = 0x7fffeb7ce887 (filename not found) [in libsystem_pthread.dylib]
 thread_start Address = 0x7fffeb7ce08d (filename not found) [in libsystem_pthread.dylib]


System Info: macOS Sierra 10.12.6 nVidia CUDA Driver Version: 8.0.90 - GPU Driver Version: 10.17.5 355.10.05.45f01

It crushes trying to load a new empty project created with 4.17 or any other project.

Help would be appreciated thank you.

Product Version: UE 4.17
Tags:
more ▼

asked Aug 08 '17 at 12:04 PM in Bug Reports

avatar image

Sutorcen
181 7 13 18

avatar image nexuz6 Aug 08 '17 at 04:53 PM

I too have this problem.

It's when creating a new project from the 3rd person template.

avatar image BlueSpud Aug 08 '17 at 06:29 PM

Also crashing on MacBook running an R9 M370X, 12.13 beta 5. Workaround in answers does fix issue

avatar image Tiefsignal Aug 09 '17 at 08:36 AM

Im having the same Problem in the Editor when opening a level while playing. Im using also an AMD Card, thats why I'm posting this in here.

avatar image Tim C ♦♦ STAFF Aug 09 '17 at 12:56 PM

Hi Tiefsignal,

What is the callstack for your crash? I just want to make sure you are getting the same crash, and not just one that seems similar.

Tim

avatar image Tiefsignal Aug 09 '17 at 01:02 PM

Hi Tim The first three times I opened a level it crashed. After your response I tried it again for the call stack and everything went fine! Probably your response was magic...

avatar image heteroclito Aug 15 '17 at 02:51 PM

Also crashing on MacBPro, wen I opened for firs time, asks me to actualice the Xcode, but any way it crash any time even making a new project.

avatar image heteroclito Aug 15 '17 at 02:52 PM

Also crashing on MacBPro, wen I opened for firs time, asks me to actualice the Xcode, but any way it crash any time even making a new project.

avatar image Sutorcen Aug 22 '17 at 06:51 AM

Any news on this? Still can't run 4.17.

avatar image Sutorcen Sep 05 '17 at 07:05 AM

A reply would be nice. "Yes we are looking into it." "No, there is nothing we can do." Anything really at this point. It is almost one month now and we still can't work with 4.17. This is causing a serious delay on our schedule and we need to know how to proceed. Please, a reply would be nice. Thank you.

avatar image Tim C ♦♦ STAFF Sep 05 '17 at 03:12 PM

Hi Sutorcen,

Sorry for the delay. Are you still using 4.17.0, or do you see the same results with 4.17.1? In 4.17.1, we disable Metal for some hardware configurations that are consistent with the Nvidia/Metal conflict to try to avoid that crash. If you are still seeing this happening in 4.17.1, then your crash is probably similar to, but not identical to, that crash, and it may be one that we have not identified yet. I have not had the Editor crash when opening on a Mac since 4.17.1 was released, so the crash that I received may not have been the same one that you are experiencing.

Tim.

avatar image Sutorcen Sep 08 '17 at 11:47 AM

Hey Tim,

Thanks for your answer. I did a fresh install of the MacOs and I only installed the Unreal Engine. I installed 4.17.1 and it works. I don't know if it was the fresh install that did it or the new version. It could be the Nvidia/Metal conflict you speak of.

I just have some questions.

Can I use Metal with my Mac as I want to try the AR Kit out? Do the newer models face the same issue? Thinking about upgrading.

Thanks again. You can consider this post closed.

avatar image Tim C ♦♦ STAFF Sep 08 '17 at 01:08 PM

The Nvidia/Metal conflict is actually a conflict between Nvidia's drivers for MacOS and the Metal compiler. Unfortunately it is expected that any Macs with an Nvidia card that try to use the Metal compiler (which the Engine does) will run into this issue. We have not seen anything similar occur on a Mac that uses an AMD card.

If you are using a Mac with an Nvidia card, and you do not need Metal, then 4.17.1 should be fine since it should have disabled Metal based on your hardware. If your Mac has an AMD card, you should be okay to continue using Metal.

Tim

avatar image Sutorcen Sep 08 '17 at 01:17 PM

Cool, thank you Tim. Have a nice weekend.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Sutorcen,

I was unable to reproduce the crash that you described on a Mac. Is there a specific template that you are using when you create a new 4.17 project? I tried with both a Blank Blueprint project as well as a Basic Code project, and they both opened fine in the Editor.

I do not think that this would cause the issue that you are experiencing, but we are aware of an existing conflict between the Nvidia driver and Metal. Since your Mac has a Nvidia card (mine is using an AMD card), try opening the ConsoleVariables.ini file and remove the semi-colon (;) at the beginning of the following line: ;r.Shaders.Optimize=0

This will disable Metal, but may allow you to open the project if that conflict is actually what is causing the crash that you are seeing. If it does resolve the crash, you will be able to continue working on your project at the expense of some rendering efficiency. Once the conflict is resolved, you can replace the semi-colon and regain the benefits of Metal.

If that does not resolve the issue, could you please provide any additional specific information you may have about your repro that may help us to reproduce it here?

Tim

more ▼

answered Aug 08 '17 at 04:02 PM

avatar image Tim C ♦♦ STAFF Aug 08 '17 at 05:18 PM

Hi Sutorcen,

I was able to run some tests on a MacBook that has an Nvidia card, and I was able to reproduce the crash that you described there, as well as verify that the workaround that I mentioned above does seem to provide a temporary resolution while the conflict between the Nvidia driver and Metal is investigated.

Tim

avatar image nexuz6 Aug 08 '17 at 08:16 PM

I can also confirm that the workaround works.

avatar image Sutorcen Aug 08 '17 at 08:47 PM

Thank you Tim for your answer.

Ok I tried the workaround. I'm guessing you are referring to the ConsoleVariables.ini that is located in User>Unreal Engine>Engine>Config folder. Unfortunately I am still having the problem.

I run 4.17 up to the point where it asks you which project to you want to open, since I only have projects prior to 4.17, it asks to create a copy etc etc. On the other hand I can create a new project. No matter what I've tried (with dektop quality), no matter which project I chose it crashes at about 91% into loading.

Please let me know If I edited the wrong ConsoleVariables.ini.

Vangelis "Sutorcen" Angelakis

avatar image Tim C ♦♦ STAFF Aug 08 '17 at 09:37 PM

The ConsoleVariables.ini file that you edited is the correct one. I just wanted to confirm that after uncommenting that line (removing the semi-colon), no existing projects or new projects are successfully opening in the Editor. This may be a silly question, but did you make sure to save the change to the file before trying to open a project in the Editor?

Tim

avatar image Sutorcen Aug 08 '17 at 09:41 PM

No question is silly. I did ask myself that too. I will run some further test and see if I can get it to work. Maybe a whole system reboot (windows habits) will make it work. I'll get back to you tomorrow as it's getting late here. :)

avatar image Sutorcen Aug 09 '17 at 09:42 PM

So I tried various things. I cleaned up my Mac freeing up space plus all the maintenance scripts, I restarted the OS, tried to create new projects, tried to run the created projects off an external HDD but nothing. I even reinstalled 4.17. I also confirm that ConsoleVariables.ini is properly edited.

4.17 will just not run, I got up to 96% loading and that's the highest it got. Let me know if I can provide you with any more information.

avatar image Tim C ♦♦ STAFF Aug 10 '17 at 07:19 PM

That is somewhat strange. I was able to get the exact same crash that you described on a Mac with an Nvidia card, and making that adjustment to the ConsoleVariables.ini file allowed me to open projects again.

Are you still seeing the same callstack when the crash occurs, now?

Tim

avatar image Sutorcen Aug 12 '17 at 09:53 AM

Sorry for the delayed answer. Well I got some strange results. 4.17 now sometimes reaches 96% and stays there for hours without crashing and without hanging. When it crashes I get the following :

https://docs.google.com/document/d/1U84htINF4u3ZwolhZrMRmCv8eDVSn-OW3Q4skAEo9Gs/edit?usp=sharing

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I am also experiencing the same problem, but I'm really new to unreal (haven't even made a project yet) so I don't know where to go to edit ConsoleVariables.ini file. Where would I be able to edit it?

more ▼

answered Aug 14 '17 at 08:46 PM

avatar image

Andromeda_Games
1 1

avatar image Sutorcen Aug 15 '17 at 10:42 AM

If you are using windows: Program Files\Unreal Engine\4.X\Engine\Config

If you are using mac: User>Unreal Engine>Engine>Config

avatar image selektata Mar 04 '19 at 12:13 PM

Mac is

/Applications/Epic Games Launcher/Contents/UE4/Engine/Config/ConsoleVariables.ini

Then uncomment line (remove ;) from ;r.Shaders.Optimize=0 to leave r.Shaders.Optimize=0

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question