x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Swarm agent failed to kick off, common solutions don't work

Hi there.

I have some serious issues with Swarm Agent. I'm using engine version 4.16.3. Building lighting always fails at 67% of the "Exporting lighting data" process with the following message: "Lighting build failed, Swarm agent failed to kick off. The swarm agent log leaves this message at 50% of the process:

 Error: System.IO.IOException: The process cannot access the file 'C:\Lightmass\AgentStagingArea\v1.B3E64758A3E2C4852BD915EB036C21DA0C151FF5.mtrlgz' because it is being used by another process.

The swarm agent graph keeps moving forward even after both errors (As "Exporting Scene") until I force close Swarm Agent or start a new build. Here's what I tried to solve the issue, with no success:

  1. Downloaded the engine from GitHub, doesn't fix it. Tried rebuilding UnrealLightmass.cpp, doesn't fix it.

  2. Checked for duplicate meshes, materials and material instances. Renamed or deleted the ones I found. I did this multiple times (on >2000 items).

  3. Made a new empty project and migrated the map to it.

  4. Tried to delete meshes from the map. This worked after deleting several meshes (in fact the building worked even with the "corrupted" meshes after I opened and closed the engine), but only for a while. At some point, the error returns even if I delete the suspected meshes again.

  5. Cleared and validated swarm cache, multiple times.

  6. Reinstalled the engine through the launcher.

  7. Deleted the project's Intermediate and Saved folders.

I'm completely dumbfounded. Any suggestion will be tested. Thank you!

Product Version: UE 4.16
Tags:
more ▼

asked Aug 09 '17 at 01:00 PM in Using UE4

avatar image

Jono0x
21 2 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question