x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Jiggle bones A.R.T problem

Hi. I succesfully rigged my character with ART tool (maya 2015) i added jiggle bone connected to spine3. but when it skins it to my mesh it doenst moves anything.It doent's jiggle, if i try to play the animation

Product Version: Not Selected
Tags:
more ▼

asked Jul 09 '14 at 12:41 AM in Everything Else

avatar image

ihavenick
18 9 9 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Are we talking in the actual animation rig file or in the export file (where you skin and do the joint mover setup)?

In the animation rig file, on the jiggle control, check to make sure the attribute for chainStartEnvelope isn't zero. (as well as checking some of the other ones, like chain iterations, stiffness, drag, etc). Those should all have some default values, but it's possible you may have zeroed them out by accident.

If you're referring to the export file, the bones are just bones at that stage, and will not have any dynamics applied until the rig is built!

more ▼

answered Jul 10 '14 at 02:37 AM

avatar image ihavenick Jul 10 '14 at 01:16 PM

i want to make jiggle bone not chain bone

avatar image Jeremy Ernst STAFF Jul 10 '14 at 07:22 PM

I understand. They're actually the same rig, in terms of the code :)

Did you check that attribute? If it's zero, nothing will happen. Also, how are you testing it? What is it parented to? There are lots of things that will affect the dynamics, like parent motion, attribute settings, etc.

avatar image ihavenick Jul 10 '14 at 10:35 PM

i cant found that setting. i testing with jumping animation in maya. its parented to spine3 bone and its not jiggling. but i made second test.i created 2 jigglebone. first jigglebone connected to spine3 second jigglebone connected to first jigglebone and first j.b. not jiggling but second one is jiggling

avatar image Jeremy Ernst STAFF Jul 11 '14 at 12:21 AM

The fact that your second one works and the first one doesn't points to it not being an issue with the rig code, but most likely a skinning issue, or attributes not being set properly.

Here is a quick video I put together going over the attributes and settings for the dynamics:

Jiggle_Bone.wmv

I think once you watch that and try some of the steps in there, you should be able to get it working. If it still doesn't work, I'd check to make sure the mesh is skinned to the bone.

avatar image ihavenick Jul 11 '14 at 12:45 PM

Test 1.ok i looked to settings its same like yours. I added gravityforce now jigglebone is jiggling but not skinned to mesh.(i cant get it skinned)(its conencted to spine1)

Jigglle only 1 bone

Test 2 .i tested with 2 jigglebone again.jigglebone1 connected to spine2 other is connected to jigglebone1 . jb1 is strangely skinned to mesh other one is not

jiggle with 2 bone

is there a way to get "test 1" working?

p.s.=i using maya 2015

Edit= Thank you for the video and help :)

avatar image Jeremy Ernst STAFF Jul 14 '14 at 05:59 PM

hey man! So, looks like test 1 works in that, the joint is moving, but the mesh isn't skinned to it. You mentioned you can't get the mesh to be skinned to the jiggle bone. Is there a reason why? Does it throw an error or something?

avatar image ihavenick Jul 14 '14 at 06:07 PM

I doing samething but it doesnt skins.i importing mesh to maya Creating character rig with jiggle connected to spine2 Then i moving arms and legs match to mesh then i skinning to mesh (I putting jiggle to inside character mesh) but you saw the result its not skinned to but if i make 2 jigglebone its skins

Edit maya giving mayatomr plugin not found but its always saying it

avatar image Jeremy Ernst STAFF Jul 14 '14 at 06:13 PM

no error though when trying to skin? Does the bone get added to the skinCluster or does it not even make it that far. If you're getting an error when trying to add the bone to the skinCluster, go ahead and post the error up here!

avatar image ihavenick Jul 14 '14 at 06:17 PM

Maybe its a bug can you try it too? I will test and write (if there is one) error here

avatar image Jeremy Ernst STAFF Jul 16 '14 at 07:53 PM

hmm, those are all warnings dealing with the proxy mannequin geometry, so that shouldn't be an issue in this case. I did give this a shot on my end, and everything is working as expected, and the bone skins to the mesh no problem. can you send me a file? (jeremy.ernst@epicgames.com)

avatar image ihavenick Jul 17 '14 at 09:18 AM

Ok i sent .Waiting for you

avatar image Jeremy Ernst STAFF Jul 17 '14 at 09:39 PM

This file works fine once you add some weighting to the belly bone. I just went into the skin weights tool, added some weights to the belly joint, as there were none, rebuilt the rig, and bam, jiggles. this was in Maya 2015 sp2. I will email you back the export file, but I'm seeing no issues here aside from the joint not being weighted.

avatar image ihavenick Jul 18 '14 at 03:49 PM

Thank you so much. I will reinstall maya for my weighting tool doenst working.Thank you again

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question