x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Not sure if my Build is working, won't install into phone.

Hey guys, having a few problems here....

So I am successfully getting the project built - it has LITERALLY nothing in it (following the tutorial on the Unreal docs site) just the floor and basic lighting - but it takes about 5-7 minutes to package it? It doesn't even have a Gig's worth of data, completely fresh scene. This seems like a bit too long? Something seems wrong...

I followed the tutorial to a T - apart from installing the Nvidia Codeworks for Android and Visual Studio - that was a nightmare! It has to be a specific version of Visual Studio or Codeworks won't play nice. I eventually found VS v.2010, I hope that this isn't the reason I'm having issues. So it builds okay, but when I hit the BAT file to install it on my android phone, it doesn't work. There are a number of errors popping up.

I am a complete n00b at this - literally the first time I've even attempted to package anything in Unreal4, nevermind for android. Could someone please point me in the right direction for troubleshooting? All tutorials I look at have a degree of "You should know This much so I'll skip a step or 8" I literally know nothing. I don't know if the files need to be on the phone, where they should be. I'm at an absolute loss.

Help, please! Anything is greatly appreciated!

Product Version: UE 4.15
Tags:
more ▼

asked Jun 09 '17 at 08:24 PM in Packaging & Deployment

avatar image

Chinchikurin
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first
more ▼

answered Jun 09 '17 at 08:28 PM

avatar image

Sertac Ogan
1.5k 30 11 46

avatar image Chinchikurin Jun 09 '17 at 08:34 PM

Thank you for your answer, but this was the guide I was following - I get all the way to Double-click the BAT file to install it into your phone, then unplug the device and look for your app but when I double-click the BAT file, I get errors in the cmd log...

avatar image Sertac Ogan Jun 09 '17 at 08:36 PM

Can you share me logs?

avatar image Chinchikurin Jun 09 '17 at 08:43 PM

They disappear before I can screencap them. These are notable though - [DELETE_FAILED_INTERNAL_ERROR] and [INSTALL_FAILED_NO_MATCHING_ABIS]. There are also lines indicating that there are, permission problems or storage issues - I enabled USB Debugging, and "Always from this computer", checked in the dos box as per the walkthrough and everything seems fine. Phone is definitely connected. There's plenty of internal storage and I have a 32gb SD card.

The phone is a Sony Xperia Z1 Compact, it supports VR and google cardboard. Am I missing something really simple here?

avatar image Sertac Ogan Jun 09 '17 at 08:51 PM

Okey i understand problem. Your computer does not see the phone in debug mode. This this helpful. If debug mode open then you need install android driver.

avatar image Chinchikurin Jun 10 '17 at 04:26 PM

alt text

Tried to launch the game onto my phone (Took it about 20 minutes to load over 2000 shaders - this is a totally blank project with no starter content...it's beyond me.) This is the error dialogue I got.

issues.jpg (904.8 kB)
avatar image Chinchikurin Jun 10 '17 at 04:37 PM

alt text

I know that my phone is Android version 5.1.1 and it has an 800 chipset. This is what happened when I changed from arm64 to armv7.

more issues.jpg (997.8 kB)
avatar image Sertac Ogan Jun 10 '17 at 04:58 PM

Can you check build settings? Project Settings > Android

alt text

armsettings.png (13.6 kB)
avatar image Chinchikurin Jun 10 '17 at 05:24 PM

First Screenshot was Support arm64, the second screenshot was Support armv7 I didn't change any other settings. OpenGL ES2 is checked for me also, as per the walkthrough instructions.

I am currently uninstalling Codeworks and Visual Studio 2010 to see if I can re-install and solve some issues. I also tried to update my phone drivers, but they are up-to-date.

avatar image Sertac Ogan Jun 10 '17 at 05:33 PM

The only remaining option is updating all of them.

avatar image Chinchikurin Jun 10 '17 at 06:04 PM

Codeworks is telling me I need to install Visual Studio 2013 or 2015 to install a certain Nvidia sdk - I can't find 2013 so I am un-installing 2010 and trying install 2015 to see if I can get it to work.

Worst comes to worst, I'm meeting my Lecturer soon so hopefully, he will be able to help me. Thank you for lending me some of your time - I will update and let you know if it gets solved.

avatar image Sertac Ogan Jun 10 '17 at 06:07 PM

Okey Chinchikurin . I hope helpful.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question