x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

conflicting provisioning settings for iOS distribution build in Xcode

I want to create iOS build, but having some problems. I tried to create certificates and provisioning profiles from the developer.apple.com but when I used them I was having errors :(. After research I found that it is important to create certificates and provisioning profiles only in Xcode (here is one of the links)

When I set the Xcode settings so that it will create certificates and provisioning profiles for developer it creates correct certificates with its provisioning profile. I import them into ue4 and package project. Great I have a developer build :).

But I need build for distribution.

So I change the Xcode settings so that it will create certificates and provisioning profiles for distribution, but Xcode says the following:

alt text

I'm using ue4 v4.16.1 and Xcode v8.3.3

Here is my questions:

1) Am I doing something wrong? 2) Is it Xcode bug? 3) How can I resolve this?

Product Version: UE 4.16
Tags:
shot.png (50.2 kB)
more ▼

asked Jun 13 '17 at 01:24 PM in Packaging & Deployment

avatar image

Tatev
21 1 7 7

avatar image minnow Jun 28 '17 at 08:27 AM

Hello Tatev, I am using same UE4 version and Xcode version. I also have a this issue, Did you solve this problem?...

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Ok here are the steps:

1) Create certificate from Xcode : Xcode->Preferences->account setup->Mange Certificate -> click on "+" button and choose iOS App Store

2) in KeyChain Access : find the certificate (iPhone Distribution) and export it. It will create file with .p12 extension

3) Goto Developer Account and create Provisioning profile for distribution(choose distribution certificate that created from Xcode (step 1)). Download it and double click for install

4) Copy-Past the provisioning profile to ProjectDir\Build\IOS and rename it to projectName

5) Open project in UE4. Goto project settings -> IOS -> import certificate -> import .p12 file (step 2). UE4 will automatically import the provisioning profile

if after this step provisioning status will be "no valid Certificate found" then you may restart Mac. After that It become "Valid" for me :)

6) turn off project settings -> IOS -> automatic signing

7) Goto project settings -> Packaging -> "Build Configuration" set to "Shipping" and turn on "for Distribution"

8) open ProjectDir\Intermediate\IOS\ProjectName.entitlements file and be sure that "get-task-allow" is set to "NO"

9) File -> package project -> IOS

more ▼

answered Jul 04 '17 at 08:20 AM

avatar image

Tatev
21 1 7 7

avatar image Jason_Qin Sep 10 '17 at 04:09 PM

Hi @Tatev, I don't found automatic signing of 6).

avatar image ZN-Games Mar 19 '18 at 03:17 PM

I tried this with 4.18 & 4.19 on a fresh project but it doesn't work for me. Building for distribution is really frustrating...

avatar image mike_patterson Aug 24 '18 at 11:15 AM

Really appreciate you outlining all this out, but unfortunately I just tried all of these steps on a Mac running Xcode 9.4, macOS High Sierra, Unreal Engine 4.20, and it immediately gave me an invalid signing certificate error when I tried packaging, despite all certificates and provisioning profiles being valid. Such a disappointment that this is such a pain in the ass.

avatar image Antidamage Aug 25 '18 at 12:16 AM

It is a pain but once it works it'll be fine.

You shouldn't need to follow the steps above. Do everything you can on the apple dev certificate site and let XCode sync your certificates. Don't bother loading anything into UE. They should just appear.

It also may be worth deleting all of your old cert and profile attempts, which are in a common location for all profiles.

(comments are locked)
10|2000 characters needed characters left

Hello Tatev,

I have same problem 3 weeks ago. When I woke up the next day, the error was lost. So I think you should wait a bit approval of the certificate .Goodluck :)

more ▼

answered Jun 13 '17 at 01:29 PM

avatar image

Sertac Ogan
1.5k 30 10 46

avatar image Antidamage Jan 11 '18 at 02:28 AM

The reason it worked for you the next day was because there is a very old bug in Apple's certificate process whereby if you're ahead of a certain timezone (such as off continental America) your certificate won't be valid until the next day. I can't fathom why, but there it is.

On the day you create your certificate, set your build machine's date forward by one day. This will fix the issue. A day later you can set it back to the correct date.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question