x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Crash in Packaging

Hi folks,

since we updated the engine for our project from 4.14.3 to 4.16.1 I got crashes in the packaging process on Linux. The packaging is started via a couple of shell scripts, but the final command line is:

 Start UAT: mono AutomationTool.exe BuildCookRun -nop4 -nocompile -project=/home/jmueller/src/game/game.uproject -cook -allmaps -stage -archive -archivedirectory=../Packages -package -LinuxNoEditor -clientconfig=Development -ue4exe=UE4Editor -pak -targetplatform=Linux -build -utf8output

which generates this log:

 Unhandled Exception:
 System.TypeLoadException: Could not load type 'UnrealBuildTool.XmlConfigLoader' from assembly 'UnrealBuildTool, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null'.
 [ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type 'UnrealBuildTool.XmlConfigLoader' from assembly 'UnrealBuildTool, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null'.
 RunUAT ERROR: AutomationTool was unable to run successfully.

My guess would be that something in the AutomationTool or Mono is broken. I already made a clean build of engine, editor and game but this did not affect the error. Currently I dont have any clue what might cause this problem or what to do about it. So I would really appreciate any recommendations or hints on this topic.

Kind regards and thanks in advance.

Product Version: UE 4.16
Tags:
more ▼

asked Jun 13 '17 at 03:59 PM in Linux

avatar image

j.mueller RFG
304 3 10 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Does the same problem happen in a freshly cloned stock 4.16 from github? If it does not, please make sure you cleaned your repo from files possibly left over and rebuilt the UBT (the former may require some manual examination).

more ▼

answered Jun 13 '17 at 04:34 PM

avatar image

RCL STAFF
2.7k 59 6 88

avatar image j.mueller RFG Jun 30 '17 at 02:53 PM

Yes, it seems as if this has been caused by some left over cache files. Thanks a lot for your help.

avatar image illYay Sep 07 '17 at 08:33 AM

I'm having this problem too. Where did you delete the cache files from? I tried clearing Saved folder in UE4 and that didn't help.

avatar image j.mueller RFG Sep 07 '17 at 10:34 AM

Try to delete DerivedDataCache, Intermediate and Saved folders in game and engine folder. Then re-run Setup.bat/sh and GenerateProjectFiles.bat/sh and you should be good to go.

avatar image illYay Sep 08 '17 at 12:40 AM

Oh OK. I got desperate enough that I just nuked my whole engine and rechecked out and rebuilt from scratch. Worked flawlessly as it should.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question