x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cant get UMG tutorial item text to show in viewport

alt text

Ok so I did the tutorial and everything worked perfectly fine cool. Next I started a new blank project no starter content took and migrated the first person character from a new first person project as well as the third person character from a new third person project over to my blank one. I then combine them then aliened the camera and attached it to the third person characters head. I then opened the UMG project and started pulling out the BP's I wanted and only the nodes I wanted I took the Pickup Text and the Inventory Struct. The Pickup Template actor I made a new one in the empty level project and started putting in the nodes I wanted the only thing in here is the setting of the variables, everything that was in the construction script and the part that adds the text widget to viewport when the character stands in the trigger volume. So none of the pickup, drop, inventory itself, or use functionality has been brought over yet as none of that has to do with the text widget I figured it wouldn't effect it. Well its not working in the pickup template I put in the node "is in viewport" to get rid of the warning then I did a brake point to check what was being passed in and everything seams to be getting set and done properly but still no text appears over the object.

I'm guessing since this is a blank project I maybe have to enable something or I missed something idk. After going back through the UMG tutorial and a bunch of head desks along with google searches coming up with nothing I figured I would ask and see if anyone had an idea as to why this is happening. I thank you all for any help in advance.

Product Version: UE 4.16
Tags:
pickuptemplate.png (376.4 kB)
more ▼

asked Jun 14 '17 at 01:17 AM in Blueprint Scripting

avatar image

Valcare
13 4 4 7

avatar image Valcare Jun 14 '17 at 02:16 AM

Also on a side note I noticed that when you walk over the object the text disappears and wont come back till you end session and restart. I get no errors or warnings so i'm guessing its just how the UMG tutorial was done that produces this effect not sure why or how to fix it though

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Figured it out I made a custom player controller and didn't set it up so yea everything that mattered was broken :P

more ▼

answered Jun 14 '17 at 06:39 AM

avatar image

Valcare
13 4 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question