x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

How to let light shine through static mesh from inside it

Hey guys, I have a lamp wich shines light 360* with an IES profile. The Mesh has some emissive fields going on so the point light needs to be inside the lamp mesh. The problem now is that the light does not come through the static mesh, the material is not two sided so actually should it be working. but it does not. Any help is appreciated! Thanks in advance :) ps: both sm and pl are placed in a blueprint (tested it outside: same result)

Product Version: UE 4.16
Tags:
more ▼

asked Jun 15 '17 at 11:38 AM in Using UE4

avatar image

IONSTUDIOSMEDIA
2 2 3 5

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Got the answer on another question, still not the perfect solution but it works!

https://answers.unrealengine.com/questions/669489/let-light-ignore-geometry-inside-blueprint.html

more ▼

answered Jun 21 '17 at 10:04 PM

avatar image

IONSTUDIOSMEDIA
2 2 3 5

(comments are locked)
10|2000 characters needed characters left

The most straightforward path is to set your lamp mesh material to unlit or disable shadowcasting from your light mesh.

more ▼

answered Jun 15 '17 at 12:47 PM

avatar image

Deathrey
7.8k 130 30 292

avatar image IONSTUDIOSMEDIA Jun 15 '17 at 03:32 PM

the unlit method does not work and wouldn't be an option in my case. And the disabling of the shadowcasting of the light is also not intended bc the light should cast shadows but not on its self. It is somehow possible for the light component to ignore itself or the static mesh or (all other components that are in the blueprint)? Thanks :D

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question