x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

HTML5 404 Error (and large file sizes?)

I have a new 4.16 project with no starter content under the "blank" template. I made a new blank map and set that as the default map.

I run the HTML5 packaging option and end up with a build like so:

alt text

Running the HTML5LaunchHelper.exe and opening localhost in chrome results with this error

alt text:

My chrome version is up to date (Version 59.0.3071.86 (Official Build) (64-bit)) What am I supposed to do here?

Bonus question, why is my build so huge for a project with nothing in it?

Product Version: UE 4.16
Tags:
more ▼

asked Jun 15 '17 at 04:30 PM in Packaging & Deployment

avatar image

Gorlock
6 2 4

avatar image Mistform05 Jun 19 '17 at 02:36 PM

I have the same issue, can't seem to find any documentation on how to get the project to run off Amazon S3.

alt text

capture.jpg (62.9 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Try doing a build that targets WebAssembly. That will replace the .asm.js file with a much smaller .wasm file. Also enable gzip compression of the .wasm file to serve a .wasm.gz file which should come down to about 10MB.

The .data file however depends on the content of your project. Perhaps the template has that UE4 starter content in it, which contains lots of assets that the template doesn't need but which are provided for playing around purposes. There should be a checkbox somewhere with "include starter content" or similar.

There should also be an option to compress the .data file. You can try gzip compressing the file to check if it is already compressed (if it is compressed, then gzip compressing again doesn't reduce file size further)

Check out the .html file, and in particular the part "const serveCompressedAssets = true;". If you don't have .gz compressed assets, then set that flag to false.

more ▼

answered Jun 15 '17 at 07:33 PM

avatar image

juj
896 13 4 16

avatar image Gorlock Jun 18 '17 at 08:38 PM

I definitely have no starter content in my project - I made it blank and with the checkbox disabled just for that purpose.

When I use the option to "Compress files during shipping packaging", it seems to spit out even more files? Even after changing that boolean in the html I still get errors. Can you confirm you can load your build after compressing and changing the variable?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question