x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Google play login not working in published app

I have already made some apps and every app works fine until now... since the new developer console of google play i can't get my login to google play to work.

I have : Done this

I have published my app as production in the google play console I have done all the gameservices checks (all green V's) and published it

alt text

i'm sorry for the dutch version of this picture but it is saying it is ok and working... :P but after all these steps I still get this in game...alt text

after that i can't open my leaderboard and stuff like that...

any ideas on this problem??

Product Version: UE 4.14
Tags:
more ▼

asked Jun 18 '17 at 04:28 AM in Packaging & Deployment

avatar image

mmikee85
6 1 2 1

avatar image zamnaz Jun 19 '17 at 04:16 AM

Facing the exact same issue here as well. Done all the necessary work in the console and in the app, when I pack it and manual copy the apk to my phone and test, it logs in just fine. Leader-boards also pop up but doesn't show any information

alt text

However when I upload that same apk to google play and download it from the store the login always fails. And so leader-boards don't show up. Could we please get some help on this!

avatar image mmikee85 Jun 19 '17 at 04:41 AM

found the problem after hours and hours of trying if found that Google Play App Signing is the problem re-reupload you app and don't enable this function alt text

problem3.png (73.6 kB)
avatar image zamnaz Jun 20 '17 at 01:38 PM

Yeap that fixed it! Thanks mate! Anyone who's going through this problem just make sure not to opt in for Google play app signing.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first

Thanks for the post resolve, i was reading alot about this because i get a very similar problem, that's what i thought may be the solution, but it will be interesting to find a step by step guide on how to get logging in to work with google play app signing enabled

more ▼

answered Mar 11 '18 at 10:52 PM

avatar image

Nightform
1

avatar image silverfish1000 Oct 08 '18 at 06:25 AM

I done the above right off the bat but problem persist. Still can't log in to leader board. Log in seem to execute and shuts down right before show the leader board deal. There must be something to do with permissions because if it works fine from direct install and then wont do the same after Google Play download is because of android permissions. Cause now your giving it out to the world so you have to be aware of privacy laws. If you don't give permission to user then the next function that should work wont work. It wont telly you need android permission it just shuts down like Chernobyl nuclear reactor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question