x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Particle spawns even if rate is 0

I set the emitter spawn rate distribution to 0 constant but if i play oder simulate the level the particle system still spawns particle. Why?

Product Version: Not Selected
Tags:
more ▼

asked Jul 09 '14 at 03:28 PM in Using UE4

avatar image

Nija
61 9 13 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

The level of detail seems to manage the particle spawn rate. Because my particle system was far away the particle spawned. Change the LOD mode to "direct set" will stop the particle spawning.

more ▼

answered Jul 10 '14 at 09:27 AM

avatar image

Nija
61 9 13 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Nija -

Here are somethings which you can check:

1 - Did you actually save the change to the emitter module? Sometimes this can help update to emitter in the level to match the emitter in Cascade.

2 - Assuming it is the way you want it in Cascade, try pressing restart in level to see if doing so refreshes it to match.

3 - Have you added another full emitter to your particle system that is still running? (If so, click the X icon under the Emitters name and icon to disable it and see if it matches.)

4 - Do you have any Burst events spawning in the Spawn module?

If none of these work, can you post a screenshot of you Cascade setup so I can try to help you further?

Thank You

Eric Ketchum

more ▼

answered Jul 09 '14 at 04:03 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image Nija Jul 10 '14 at 09:21 AM

Hi Eric again :D You seem pretty active on this answerhub (2.6k karma :)). 1 - Yes I saved the particle and rebuild the level 2 - I reopend the level with the same result 3 - Yes I have 2 emitters with both spawn rate 0 and both still spawn in play mode 4 - No bursts active

Thanks alot for your response but I figured out whats the problem. It was on automatic LOD, I set it to Direct and everything works perfect. I never worked with LOD levels bevor but I will get used to it :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Nija,

0 in the distribution means that the particle should live forever - if you'd like it to be really short-lived try a value a little higher than this.

Thanks

Andrew

more ▼

answered Jul 09 '14 at 03:58 PM

avatar image Nija Jul 10 '14 at 09:05 AM

Hi Andrew, I was writing about the spawn rate of a particle and not about the lifetime but thanks for your response

avatar image arbrown STAFF Jul 10 '14 at 09:12 AM

Ah, sorry my mistake Nija... best to follow Eric's suggestion then, thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question