Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How can I fix my Scene Lighting from being too bright?

So I am working on a game project where I am trying to make a blue and cloudy looking toony sky with good lighting.

I have been playing around with this some off and on including watching youtube videos but for some reason I still cannot seem to figure out how to stop the camera from becoming blinding when looking at the ground.. :(

From that and the tutorials I messed around with the colors, the intensity, the light and sun direction and rotation, setting the light source but I think I am doing something wrong.

I ended up changing the color spectrum with a Scene Color Texture File to get it closer to a cartoonish look though it's still a bit off. Not sure of a better way?

If I look one direction it looks fine but if I look another then it becomes overly bright and you can see the change occurring and switching up.

I would appreciate any help or advice to help me fix this. I would just buy one or something but I cannot afford it right now and was trying to figure it somehow. Any ideas?

Looks Fine Here or at least closer to what I Want: (Okay Lighting): alt text

Looks Bad Here: (Bad Lighting): alt text

Here's my lighting settings if this helps:

alt text alt text alt text

Product Version: UE 4.15
more ▼

asked Jun 23 '17 at 06:55 PM in Using UE4

avatar image

113 14 22 26

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Sounds like you need to adjust your auto-exposure.

See this answer to do it in the editor

Setting it to "Fixed at Log 0" will give you the true light and not brighten or darken it.

However, in my opinion the way to correctly fix this issue for a game is add a PostProcessVolume, check the "Unbound" box to make it apply to the whole scene, and then adjust your Min and Max Brightness values under the "Auto Exposure" group setting.

more ▼

answered Jun 23 '17 at 08:48 PM

avatar image

171 2 3 7

avatar image Deygus Jun 23 '17 at 08:52 PM

Awesome, thank you so much for the help and I will go ahead and look at that more now!

I actually have a PostProcessVolume I added in there which contains a texture I created to adjust the scene colors that I was trying out.

avatar image Deygus Jun 23 '17 at 09:03 PM

UPDATE: Yep, that's the problem. When I changed it to the Exposure at Log 0 it stopped doing that and is staying constant.

I'm gonna leave it this way for now because not really sure how to do it properly with the second suggestion using the post process volume. I did what you said but didn't do anything, maybe I didn't do it right..

Anyways, thanks, this is extremely helpful!

avatar image Deygus Jun 23 '17 at 09:05 PM

UPDATE: Okay, nevermind, I got the second one working! Thanks a ton!!!

avatar image Rushidimber Jan 13 '18 at 01:23 AM

That 2nd one I didn't know that Thank You.

avatar image Pharmadude Jun 03 '18 at 01:14 AM

This helped me too. Thanks :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question