x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')

Hi all,

Since the release of drivers 382.33 on the 22nd of May, several Unreal Engine 4 games have been affected by heavy system crashes that make playing such games impossible.

The issue I'm talking about is this one: https://issues.unrealengine.com/issue/UE-42280

The problem persists even after the release of the drivers 382.53 on the 9th of June.

The last working drivers seem to be 382.05 released on 4th of May.

As such, I would like to receive all possible information on this issue, on what is causing it and how to circumvent it if possible. Even more important, I would like to know if Epic Games is actively working with Nvidia to solve this issue at its source (like AMD should be doing, as stated here: https://community.amd.com/message/2802464 )

Thanks a lot!

Here's an open list of games experiencing (allegedly) the same problem:

Dead by Daylight

https://steamcommunity.com/app/381210/discussions/7/135509472107458932/?ctp=7

Downward

http://steamcommunity.com/app/506900/discussions/0/1290691308590233607/

EVERSPACE

https://forum.everspace-game.com/discussion/4400/crash-roport

Friday The 13th - The Game

https://www.reddit.com/r/F13thegame/comments/6e8pna/unreal_engine_is_exiting_due_to_d3d_device_being/

Little Nightmares

https://steamcommunity.com/app/424840/discussions/0/2119355556490497561/

Playerunknown's Battlegrounds

http://forums.playbattlegrounds.com/topic/28103-unreal-engine-is-exiting-due-to-d3d-device-being-lost-error-0x887a0006/

TEKKEN 7

https://steamcommunity.com/app/389730/discussions/0/1291817837622204814/

Product Version: UE 4.15
Tags:
more ▼

asked Jun 24 '17 at 08:18 AM in Bug Reports

avatar image

FraZack
21 4 7 9

avatar image Spacemonkey907 Jun 27 '17 at 01:05 AM

I am all about this issue right now. Please help!

avatar image RAKESH KAMAARA Jul 10 '18 at 09:06 PM

if you are using a laptop.. do the following first.

  1. connect your laptop to charger. open unreal engine and open file menu and hover mouse over it. if it works fine leave it. mostly the crash won't happen.

  2. disconnect your laptop from charger. now again... open unreal engine and open file menu and hover mouse over it. MOSTLY NOW... THE CRASH MAY OCCUR.

IF THE CRASH OCCURS.... DO THE FOLLOWING.

NVIDIA GEFORCE EXPERIENCE -> GAMES -> BATTER BOOST -> DISABLE IT !!!!!!

AFTER DISABLING BATTERY BOOST ON NVIDIA GEFORCE EXPERIENCE.. TRY THE ABOVE 2ND STEP AGAIN. NOW..IT SHOULD BE WORKING FINE MOSTLY.

CHECK AND REPLY.alt text

gfe.jpg (336.8 kB)
avatar image impostekno Dec 31 '18 at 07:29 PM

Thanks man, worked for me and appreciate your help

avatar image S-ed Jun 27 '17 at 05:56 AM

Main problem is. Even if Epic will solve this issue in engine, it still will be in late versions. Dev's should patch each game individually. And that's probably won't happen (one can not simply update ue4 version).

avatar image Spacemonkey907 Jun 27 '17 at 10:04 PM

So we are screwed unless Unreal Engine people do something????????

avatar image hexaae Oct 15 '17 at 06:11 PM

Add to the list of affected games: Hellblade - Senua's Sacrifice

avatar image Noctane Jan 26 '18 at 03:23 AM

You can add Ark: Survival Evolved to the list of affected games.

avatar image Noctane Feb 12 '18 at 07:22 PM

I see there is a jira bug ticket on this issue: UE-42280 & UE-51650, I have two EVGA Nvidia 760 in SLI configuration. Looks like UE team is trying to figure out how to reproduce, maybe this will help?: I crash maybe every 3 minutes in ARK on the Island map, sometimes I can make it a few hours without a crash but thats pretty rare. Sometimes I'll crash when opening any inventory, sometimes when it's dark on the screen I crash. During hard rendering of scenes you would think it would crash but it seems to do fine.

avatar image hexaae Feb 24 '18 at 07:03 AM

This bug is still present even with UE4.17 games... https://issues.unrealengine.com/issue/UE-51650

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first
more ▼

answered Jun 27 '17 at 05:44 AM

avatar image

S-ed
1.3k 27 23 43

(comments are locked)
10|2000 characters needed characters left

This is still happening in version 4.18. This may help people working on this, as I got a clue as to what is going on when I solved this. My ancient laptop brought me here. I have a Toshiba laptop Win 10 w/ 4GB RAM with an AMD E1-1200 APU with Radeon HD Graphics 1.4 GHz (yeah, a pukie system that I use to test worst case scenarios). I get this error every time when my laptop is unplugged and is using battery only. When it is plugged in however, no issues whatsoever (except the awful lag that is expected). This may also be why some people are finding this issue intermittent. In the case of a desktop computer does one have good power with enough wattage to support their video card?

more ▼

answered Feb 22 '18 at 05:11 AM

avatar image

RobMilliken
22 2 6

avatar image Jake1337 Mar 05 '18 at 08:50 PM

Thank you so much! This solved the issue for me (also using 4.18.3, this issue is definitely still unsolved).

I encountered the error minutes before an important presentation and your comment saved my *** :) I would've never guessed it myself... and yes this issue was intermittent and I could not figure out why.

As for the lag - I assume you mean the ~0.5 second delay that comes with showing the video stream in engine? If so then first off all it's comforting to know I'm not the only one having this issue... and second, have you found any means of minimizing this lag/latency?

avatar image RobMilliken Mar 08 '18 at 07:46 AM

I am glad that your issue got resolved with my help!

I think that Epic may be getting a "bad rep" because of this issue. I think the error needs to be clarified when shown adding the possibility of a power issue with their video card. EG: Running a desktop computer with a high end GPU and only 350 watt power supply for example could increase risk for this happening. The error may even be a good in regards to preservation of the video card and their computer system itself.

In regard to the lag, I completely expect that. It isn't streaming - it is a very low level laptop running some of my game demos for demonstration at the Unreal Discussion group in Pittsburgh, PA. It won't even run the editor. As referenced earlier, I noticed the issue when I had decided not to bring my power supply and working off of battery as I would be testing at a library location to be sure the internet was working (the demo project was on web widgets in Unreal). The speed of the CPU / graphics card though I don't believe had anything to do with the error - the power to the GPU did.

(comments are locked)
10|2000 characters needed characters left

Had this issue trying to play Fortnite on Windows 7, this is how I was able to resolve it.

I had a bit of a hard time with it and verifying did not do the trick, after some failed attempts of finding the solution I got tired and just did all I could think of to remedy the issue.

What worked for me was:

Changing the registry settings for the graphics adapter to cause it wait a bit longer before crashing in case the adapter was halted, these are the DWORD I added:

Registry Path:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers

DWORD:

  • TdrDdiDelay=10

  • TdrDelay=10

  • TdrLevel=0

  • TdrLimitCount=10

  • TdrLimitTime=180

I then installed the latest DirectX driver from the microsoft update site for Windows 7.

Link: https://www.microsoft.com/en-us/download/details.aspx?id=36805 (KB2670838).

In retrospect, probably just installing the driver could have solved it, but since I had already made changes to the registry, I figured I'd just modify it with the available values.

Hope this helps someone.

more ▼

answered Apr 14 '18 at 10:53 PM

avatar image

MindProxy
1

avatar image Kokuyouseki Feb 05 '19 at 07:12 AM

Ran into this error with my game/presentation, packaged in 4.19.2 on an old rig, win7, integrated graphics card on some gigabyte G31M motherboard. Or was it Asrock?

Anyways instead of being ridiculously slow it just won't run. I presume it does require an actual, not completely trash vidcard with installed drivers :).

(comments are locked)
10|2000 characters needed characters left

Dear all,

I install NVIDIA Nsight Graphics and it's work for me...

Cheers....

more ▼

answered May 01 '18 at 10:29 AM

avatar image

gurudatt
1 1

avatar image AngelOfChaos56 Jan 09 '19 at 02:15 PM

I have tried posting a comment several times. Here is try # 4. I am having this issue in Atlas. Repeatedly. I have installed the updates for all of my drivers, verified game cache, not working. Is there not a permanent fix yet? This seems like a very old issue that should not be happening alt text

fatalerror.png (58.3 kB)
avatar image S-ed Jan 10 '19 at 09:32 PM

Atlas is using old UE4 version. Prior to this fix. Ark was using UE 4.5.1.0.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question