x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

120FPS in editor but only 20 in Game

Hello everyone, i'm looking for some help. When i'm editing my project, everything is okay i'm at 120FPS but when i try to play at my game, i just have 20fps even in really low settings. Join at my question you could find a UnrealStat file, as you can see when i start the game everything is crazy, but what is really strange is my CPU is only at 20% of is capacity and my Video card at 30% If someone can explain to me what i'm doing wrong would be nice

edit : the stats are 25Mo and i can't post it here, i can provide some screenshots if needed

My config : GTX 1080TI Asus Founder's Edition // I7 4790k overclocked // 16GB RAM DDR3

Product Version: UE 4.15
Tags:
more ▼

asked Jun 26 '17 at 09:32 PM in Rendering

avatar image

mouki76
1 2 2

avatar image onealexleft Jun 26 '17 at 10:29 PM

Have you tried making a development standalone build then running some basic profiling on it? Such as 'stat unit' or 'stat startfile' 'stat stopfile'? Any info from those would be helpful, as well as checking the logs when you run the stand alone game.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ensure that you don't have Frame-rate Smoothing set in your Project Settings. If it's checked, just uncheck it. It could be trying to smooth you down between 30 and 45 frames.

If that doesn't work, I think using the console command 'r.stat unit' will give you high level information about what could be bogging down your framerate. The 3 important ones are "Game" "CPU" and "GPU". All 3 of these should be relatively close in execution time.

If the value for Game is higher than the others, then it is likely that your Game logic is causing the bottleneck, which means you would have to re-examine your blueprints or C++ code to see how it can be optimized - or if there is a major bottleneck in there somewhere.

If the value for your CPU is higher than the others, it could mean that your draw-calls are causing a framerate bottleneck. You could have too meshes that aren't optimized for gaming by containing too many vertices. If this is the case, you likely have to go back and try to decimate them or find a way to optimize their usage.

If the value for your GPU is higher than the others, it could be that your lighting is causing a bottleneck. Are your lightmap resolutions too high? I can't recall if textures get rendered on the GPU, but if so, then that could be another area - your texture resolutions are too high.

more ▼

answered Jun 27 '17 at 07:42 PM

avatar image

arrpeatwo4
171 2 3 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question