x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Making a UObject tickable makes it tick in-editor

Hi, I am having some trouble making a UObject tickable. I have made a UClass inherit from UObject and FTickableGameObject, and have implemented the class correctly. The problem, however, is that the Tick event starts in editor while I'm not in play, IE right after I compile the code.

I am aware of the method isTickableInEditor, but overriding it to return false has no effect whatsoever on the behaviour. It is said in this thread that it is a known unreal bug, but you'd think that such a big problem would be solved already given how long ago it was reported. Nonetheless, I tried all the workarounds that seemed to work provided in the same thread, but none do it for me. I'm running 4.16, if that matters.

 // .h file
 bool IsTickableInEditor() const override;
 
 // .cpp file (UMessageDispatcher is my class and inherits from UObject and FTickableGameObject)
 bool UMessageDispatcher::IsTickableInEditor() const
 {
     return false;       // this does nothing
 }

The workarounds consist of making the isTickable behaviour return true or false depending on the state of the game, but in my case it either returns true both in the editor and during play, or false in both cases. I have been working on this issue for two days, but I cannot seem to figure it out. Help would be really appreciated!

EDIT: TO BE CLEAR: I want the UObject to only tick during play, not while in editor. I would like to either be provided with a solution or a suitable workaround!

Product Version: UE 4.16
Tags:
more ▼

asked Jun 29 '17 at 03:25 PM in C++ Programming

avatar image

Obelisk_Ali
8 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You might want to check this solution, it might be very possible that what is ticking is your CDO which UE uses internally.

more ▼

answered Dec 05 '17 at 07:41 PM

avatar image

Vertex Soup
288 4 22 16

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question