x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Multiple agents on navmesh, 1 agent type wont move at runtime

The second navmesh (orange) draws in editor implying the correct setup, but on begin play the orange navmesh disappeared and the car actor will not move. Any ideas ?

I have also added the agent page setup. ingame capsule collisions are set to those seen in the agent settings.

alt text alt text Best, Ben.

Product Version: UE 4.16
Tags:
a.png (1.4 MB)
b.png (78.0 kB)
more ▼

asked Jul 03 '17 at 04:58 PM in Using UE4

avatar image

bennetherwood
189 21 21 34

avatar image ColdSteel48 Dec 10 '17 at 01:14 PM

Did you solve it ?

avatar image ColdSteel48 Jan 03 '18 at 08:22 PM

Default querrt extincts should be larger than agents radius and height respectively

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Are you using the crowd following AI controller by any chance? It seems the crowd controller doesn't support multiple agent types. Changing back to the default AI controller fixes this for me, not that it's documented anywhere.

more ▼

answered Aug 15 '17 at 12:07 PM

avatar image

DavidSolfar
36 2 4 11

avatar image bennetherwood Aug 17 '17 at 07:00 PM

The controller inherits from the standard AiModule.Aicontroller class. I did not have any crowd detour ect enabled when this issue occurred, although I have since enabled this and the issue still persists. Namely the orange navmesh disappearing.

Thank you for responding, anymore ideas ?

Ben.

(comments are locked)
10|2000 characters needed characters left

Did you manage to solve this issue? I'm currently running into the same thing. The Navmesh only seems to use the 1st supported agent and never generates the 2nd one (even though it IS drawn in the editor view).

Thanks

more ▼

answered Jan 31 '19 at 02:22 PM

avatar image

DaanKools
1

avatar image ColdSteel48 Jan 31 '19 at 03:02 PM

Forget about it, this is hard-coded by Epic!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question