x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Broken Cubemap in 4.2

I'm having an issue with a cubemap which results in what looks like bad texture coordinates.

The problem only appears when I deploy to my phone and only started happening when I moved to 4.2 from 4.1, on 4.1 everything was fine.

On 4.2 the cubemap appears perfectly fine in the editor as well as mobile preview, it just becomes distorted when on the phone.

I wondered if there's any suggestions out there on how to fix this issue?

Thanks

Here's my material:

alt text

Product Version: Not Selected
Tags:
mat2.jpg (279.8 kB)
more ▼

asked Jul 09 '14 at 08:56 PM in Rendering

avatar image

Maddius
146 14 20 24

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I would guess it's due to low precision in the pixel shader on device. Phones use half precision for pixel shader operations, like anything plugged into Emissive or BaseColor. Vertex shaders will usually use full precision, which is inputs like WorldPositionOffset, CustomizedUV. Try using Customized UVs to pass through your computed UV, and then only do the texture lookup in the EmissiveColor chain.

https://docs.unrealengine.com/latest/INT/Engine/Rendering/Materials/CustomizedUVs/index.html#mobilespecific

more ▼

answered Jul 10 '14 at 01:19 AM

avatar image

DanielW STAFF
1.9k 31 11 72

avatar image Maddius Jul 10 '14 at 09:02 AM

Thanks for the reply, I will try that, however it seems very odd that it worked perfectly fine on 4.1 but on 4.2 its broken, has this precision change happened in that update?

Visually it kind of looks like the texture is being border clamped, its quite odd!

avatar image Maddius Jul 27 '14 at 12:11 PM

Just to bump this, I have tried using CustomizedUV, however these pins do not accept a 3D vector as the texture coordinate which is what is required for a cube map.

It seems like a bug that was introduced in 4.2 to be honest since it worked on 4.1, I will try on 4.3.

But any further info would be much appreciated.

Thanks

avatar image Maddius Jul 27 '14 at 06:12 PM

Looks even more broken in 4.3, would appreciate any suggestions on what this could be.

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question