x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.3 Preview > File menu and others stopped working

I opened a 4.2 project in 4.3 and that seems to work fine. I'm trying to Save All, so click on File menu and clicking on it just flashes the top bar of the editor. Edit, Window and Help menus also don't do anything. Restarting the editor doesn't change this.

Ctrl + S works to save all.

[Edit: For the project which has no menus in editor, on a different computer the same project (and menus) worked just fine after loading, but stopped working shortly after (maybe after first autosave but that's a guess). Both computers have a clean install of 4.3 Preview. The computer where the editor/project works is Windows7/NVidia Quadro card/no version control,, and the one that doesn't is Windows8.1/NVidia GTX Titan card, AlienBrain version control (thanks god) ... I'm not sure what other specs might bear on this problem].

[Edit: Might be something to do with the editor's Welcome Tutorial popup system?]

Product Version: Not Selected
Tags:
more ▼

asked Jul 10 '14 at 04:12 AM in Bug Reports

avatar image

tomofnz
1.2k 48 47 89

avatar image tomofnz Jul 10 '14 at 05:22 AM

This also affects the Play, Build, Blueprints menu drop-downs (they don't drop down).

If I start a new 4.3 project everything works fine. Just not if I open an existing project.

Uninstalling - re-downloading both 4.2.1 and 4.3 Preview didn't change this problem.

avatar image Jamie Dale STAFF Jul 10 '14 at 12:51 PM

Is this a code based project (rather than a blueprint based one)? If so, can I just confirm that you've built the "Development Editor" configuration for your project after switching it to the 4.3 UE4 build.

avatar image tomofnz Jul 10 '14 at 11:42 PM

It is blueprints only.

avatar image Oscar Cooke-Abbott Jul 12 '14 at 01:16 PM

Someone pls answer! Driving me NUTS! :O

avatar image Lucky Red Fish Jul 13 '14 at 08:47 AM

Mine is the same, no menus 3.4 converted project from 4.2.1 my project is blueprints only, none of the menus in the editor "File, edit, window and help" open

I think you broke something :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi everyone,

I have an idea of what might be causing this for you. There is a new bug with ''Enable Window Animations" which we are working to fix, and it causes all the menu issues you describe.

Please try this:

  • Close the editor

  • Navigate to the following folder in Windows for your affected project:

  • C:\Users{USERNAME}\Documents\Unreal Projects{YOURPROJECT}\Saved\Config\Windows

  • Open EditorUserSettings.ini

  • Run an F3 search for bEnableWindowAnimations

  • Is it set to "True"? ... If so, change it to False.

  • Save the ini.

  • Re-open your project

EDIT: If the setting doesn't exist in your EditorUserSettings.ini, then instead navigate to this file: C:\Program Files\Unreal Engine\4.3\Engine\Config\ BaseEditorUserSettings.ini and change the same setting to False.

Please let us know if this helps.

more ▼

answered Jul 14 '14 at 07:27 PM

avatar image

Stephen Ellis ♦♦ STAFF
11.6k 322 32 480

avatar image tomofnz Jul 14 '14 at 10:43 PM

In my engine install folder there's \Engine\Config\BaseEditorUserSettings which contains bEnableWindowAnimations and this is set to False.

But in my project's \Saved\Config\Windows\EditorUserSettings.ini the F3 tool doesn't find bEnableWindowAnimations or EnableWindow or Animations ...

So more advice required here.

[Edit: After I edited BaseEditorUserSettings I went back to the my project's \Config\EditorUserSettings (not the one in \Saved\Config\ ) and found this:

 bUseSmallToolBarIcons=False
 bUseSmallToolBarIcons=True
 bEnableWindowAnimations=False
 bEnableWindowAnimations=True
avatar image tomofnz Jul 14 '14 at 10:54 PM

Removing the two lines that say true seems to have fixed the problem ... so far anyhow. If you're happy and you know it clap your hands.

avatar image Matt STAFF Jul 14 '14 at 11:37 PM

Out of curiosity, did you enable window animations manually? It should default to off so I am just curious how it got enabled for you.

avatar image tomofnz Jul 14 '14 at 11:43 PM

I dunno. I don't recall setting that. But I did set Use Small UI Icons previously from within the editor's preferences.

avatar image Oscar Cooke-Abbott Jul 15 '14 at 07:26 AM

Setting bEnableWindowAnimations to false fixed it completely! Thankyou :)

avatar image Lucky Red Fish Jul 16 '14 at 08:07 AM

Hey thanks, like the user above there was not any bEnableWindowAnimations the EditorUserSettings.ini

\Saved\Config\Windows\EditorUserSettings.ini

however in C:\Program Files\Unreal Engine\4.3\Engine\Config\ BaseEditorUserSettings.ini

there was bEnableWindowAnimations=True so I changed it to bEnableWindowAnimations=False

Restarted the editor and bingo it has sorted the menu out!

Many thanks

avatar image Shinijami Jul 18 '14 at 06:32 PM

I have all of the following set to false yet the problem still exist. It only is an issue with my 1 project that is in Google Drive. All members of the project are having the issue and this worked just fine yesterday.

Edit: Used Sublime Text 2 and searched for the variable and it was set a second time later in the file. Sorry I had an ID107 Error but its all good now :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question