x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Update ThirdParty dll

I'm linking in a dll in c++ though edits in MyProject.Build.cs. I ended up with this though looking at various posts here:

 PublicAdditionalLibraries.Add(Path.Combine(PathToThirdPartyLibrariesFolder, "MyLinkedLibrary.lib"));
 CopyToBinaries(@"ThirdParty\MyLinkedLibrary\Libraries\MyLinkedLibrary.dll", Target);
 RuntimeDependencies.Add(new RuntimeDependency("$(ProjectDir)/Binaries/Win64/MyLinkedLibrary.dll"));
 PublicIncludePaths.Add(Path.Combine(PathToThirdPartyFolder, "MyLinkedLibrary", "Includes"));

and it works great. However, I tried to add a new function to my linked library :

 int MyNamespace::TestFunction() const
 {
     return 4;
 }

which is pretty simple compared to other functions I have successfully exported. Now, however, when I try to run game and/or Editor from VisualStudio I get error

The procedure entry point ?TestFunction@MyObject@MyNamespace@QEBAHXZ could not be located in the dynamic link library C:.....\Binaries\Win64\UE4Editor-MyProject.dll

Note that MyProject compiles in Visual Studio. MyProject compiles and runs fine if I ommit the line

 int x = myObject_->TestFunction();


I also have a separate c++ project that tests MyLinkedLibrary.dll by calling the same function and it works fine. I've also double cheked that ...MyProject.dll and MyLinkedLibrary.dll are compiled for x64. Any ideas?

Product Version: UE 4.15
Tags:
more ▼

asked Jul 13 '17 at 09:25 AM in C++ Programming

avatar image

oyvindol
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

For posterity I will write the solution that I found. At some point the build process had copied an old version of the dlls into "C:\Program Files\Epic Games\UE_4.15\Engine\Binaries\Win64" . I deleted these, recompiled, and it worked.

more ▼

answered Jul 13 '17 at 02:48 PM

avatar image

oyvindol
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question