x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UV Channel not Importing

I am having an issue with random objects not importing their UV channels I have created in 3ds. I do the same process for many different objects and import the object into UE4 and the second UV channel comes in fine. But seemingly randomly, like the model I am currently working on, no matter what I do, I cannot get a second UV channel to import. I am doing nothing different, so I can't seem to figure out what is going on. Has anyone ever had this problem?

Here is a link to the FBX file I can't get to work: https://app.box.com/s/purunwctlppqwx7xknnhavtbb69vnx9s

alt text

alt text

Product Version: UE 4.16
Tags:
more ▼

asked Jul 14 '17 at 12:12 PM in Using UE4

avatar image

DMHokie
68 15 25 34

avatar image michael93 Jul 14 '17 at 04:47 PM

Are you importing it or re-importing it? I've had trouble getting my second UV channel to come in before, when reimporting. I just deleted the mesh from UE4 and imported again as a new mesh, that's helped before for me

avatar image michael93 Jul 14 '17 at 04:53 PM

Update: Okay that's interesting, I've brought the model in to the engine myself. I got both UV channels show up. However, nothing was in those channels for me. I might try tomorrow when I have access my PC which has a newer version of the engine. I'll let you know what happens then

avatar image DMHokie Jul 14 '17 at 05:04 PM

I have had trouble getting the second channel when reimporting as well. This one doesn't seem to want to work no matter what. I tried reimporting and deleting the mesh and importing it. I even tried starting a new project all together and importing it. Nothing seems to want to bring in the second channel.

avatar image michael93 Jul 14 '17 at 05:17 PM

I imported it into blender just before and the UV maps didn't show there either. I think this might be an issue at the modeller end

avatar image ACLUND3 Nov 09 '18 at 02:26 AM

Sorry for the year later bump, but I had trouble when reimporting after adding a 2nd UV channel too. While experimenting I unchecked 'Generate Lightmap UVs' in the LOD0 and Import Settings dropdowns, saved the asset, and then reimported. Then I rechecked generate lightmaps and now I have both of my channels, plus the 3rd generated by UE4 for the lightmaps. Hope that helps someone.

avatar image Lancev Jan 04 '19 at 12:29 AM

One Extra bump for anyone else viewing this today, make sure that when exporting your UVs (in my case from Maya), that you have the UV Set 1 as your main set, or the current one when exporting. For some reason having it set to anything besides 1 means UE4 won't load the the rest of the sets.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question