x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Double mesh draw calls since 4.16

I have created a test project with the cool little v4.0.2, added 6k boxes with a basic material then went thru numerous builds to see how the scene performs in there.

It's actually getting wose in builds around v4.8.2 but then in 4.11 it sped up considerably (the performance build), and it stays kind of the same speed all the way up to 4.15.

In 4.16 (and 4.17 preview 1) the rendering times will increase from 10.8msec to 13msec however! That's a little over 2msec loss while rendering the same 6k boxes. In the stat scenerendering i did noticed the mesh draw calls got twice that many (for no apparent reason) which means the engine is actually rendering certain things twice. Or the stats gone wrong, but the slow down is still can be noticed!

Why is this? What happened? The test machine is win7 64bit, and a 1070gtx card.

Here are the screenshots from 4.15.0 and 4.17 p1. Same scene, made in v4.0.2 opened in both engine versions for the comparison.

alt text

alt text

Product Version: UE 4.17 Preview
Tags:
cubes4150.png (560.2 kB)
cubes417p1.png (580.1 kB)
more ▼

asked Jul 16 '17 at 12:54 AM in Bug Reports

avatar image

Konflict
48 5 10 12

avatar image Konflict Jul 16 '17 at 09:25 AM

Additionally just tested the stanford dragon (100k tris) placed 625 copies to the scene and in 4.15 i get the expected triangle counts, but in 4.17p1 it is twice that many.

The rendering costs is an additional 11.6msec which is huge, considering i opened the same basic scene with just one directional light present.

Collisions and most rendering features were turned off, including shadows and lightings on the model. I'm using the basic worldgrid material here and the scene were built in 4.15.0.

Comparison images from 4.15 and 4.17p1: alt text

alt text

dragin4150.png (554.5 kB)
dragon417p1.png (405.3 kB)
avatar image Ders92 Nov 06 '17 at 04:28 PM

Hi! I'm having the same issue and since I'm developing for Gear VR a double increase of draw calls is taking hard on performance. I noticed however that when removing static meshes from the scene where I used modulate blend mode (blob shadows) then I lost the expected amount of draw calls. But with other meshes that has opaque blend mode (almost all other meshes in the game) then I would lose twice as many draw calls which doesnt make sense too me. Did you ever figure this one out and if so how did you do it? I'm using UE version 4.17.2

Thanks in advance!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question