x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

I have no indirect lighting

Hi guys.

First time poster here, so be gentle with me!

I've only been using UE4 for about a week, so I'm a total amateur, but I've done hours of searching, testing, and reverse engineering other people's scenes to try and figure out what I'm doing wrong here, but I'm no closer to an answer.

As far as I can figure out, the problem seems to be that I'm getting no indirect lighting from directional lights (or seemingly any other lights). The indirect lighting slider seems to do absolutely nothing to my interiors.

To illustrate as best I can, I loaded up the beautiful Lightroom from the Unreal marketplace, made a small windowed room next to it, and built lighting. As you can see, the light behaves incredibly differently. alt text

alt text

This is what happens in every project I've started. I can make everything brighter with exposure and a few other little tricks people have shared, but nothing that gives that wonderful natural light effect seen here.

For these pictures, every element and setting has been untouched, the only change is the room I made from geometry brushes. The single directional light is the only lightsource (as far as this newbie can tell). If you need any more information, don't hesitate to ask.

No doubt I'm making some stupid little mistake, and I only hope somebody can point it out so I can carry on learning this fantastic engine.

Many thanks.

Product Version: UE 4.16
Tags:
light.png (1.9 MB)
dark.png (599.8 kB)
more ▼

asked Jul 18 '17 at 01:50 PM in Rendering

avatar image

Seadevil Whiskey
11 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey,

Seems like you're missing a Skylight in that scene.

Here is what you will need:

  • Dir.Light (acts as the sun).

  • Skylight.

  • Lightmass Importance Volume that covers your scene (That waywhen you build your lighting, lightmass will concentrate the ray calculations to that area).

  • Box/Sphere reflection captures.

These elements should help you get some basic indirect lighting. You will then need to play around with the intensity of the sun and/or Post Process Volume to get the desired exposure and brightness.

Cheers

more ▼

answered Jul 18 '17 at 08:59 PM

avatar image

RevenX
46 3 5

avatar image Seadevil Whiskey Jul 19 '17 at 10:08 AM

Hi,

Thanks for your reply!

I might not have explained myself very well in the original post, but those two pictures were taken in rooms just a few metres apart. All the elements surrounding the first one were also around the second. I even tried adding various spheres and lightmass portals from the first room, but it didn't seem to make any difference.

Sorry if I misunderstood your answer.

avatar image Kibblesticks Jul 21 '17 at 04:14 PM

Off the top of my head, did you try having only one lightmass volume and extending it over the second room just to check it's definitely not that? (Edit: actually sorry I think you're saying that's already the case?).

I'm not really versed in static lighting (mostly use dynamic) but it looks like the first image uses some kind of skylight or atmospheric fog? Could you perhaps post the list of objects in your scene (top right) just so we can see what's already there?

Edit 2: You could also perhaps try applying some of the materials from the first room to the second to see if they bounce the light at all. Sorry for the vague suggestions I'm sure it's probably just a setting somewhere.

avatar image Seadevil Whiskey Jul 21 '17 at 06:41 PM

Thank you so much my friend! I had no idea simply changing the materials from default would make such a dramatic difference. That's such a big problem solved. Huge thanks to you! alt text

alt text

Edit: Would you mind converting your reply to an answer so I can mark this as resolved? :)

2.png (884.8 kB)
1.png (1.9 MB)
avatar image Seadevil Whiskey Jul 22 '17 at 11:07 AM

So sorry to still be a bother, but it seems I'm still having a problem. I tried starting a new project and now nothing I can do will brighten the room up, even with intensity and indirect lighting turned to max on the directional and sky light, except for setting the skylight to "movable", but that seems to make everything look very flat. alt text

alt text

1.png (1.2 MB)
2.png (1.3 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Glad I could help! For posterity the first answer was to change your materials so they reflected more light.

I don't think your new room technically has any issues. That looks like pretty accurate lighting for a room that size with those windows. To fill it with more light what you could try is disabling your sphere actor and turning off "cast shadows" on your skylight.

This won't look as accurate though; in this room I'd suggest just opening up one side with a window of some sort if you can.

Just a bit of extra info: Turning the Skylight to "movable" makes it dynamic, which means it won't be used when building lighting. It'll be a constant lights source in the scene but won't be affected by geometry. That's why it looks flat. When it's set to static it is affected by geometry, and your almost completely enclosed walls block it from affecting the room.

more ▼

answered Jul 22 '17 at 01:37 PM

avatar image

Kibblesticks
151 3 14 19

avatar image Seadevil Whiskey Jul 22 '17 at 01:52 PM

Sorry, I'm not sure what you mean about the first answer? If you mean RevenX's comment I don't think I see anything about materials in his answer.

There are actually a few more windows on the opposite side, though you're right in that they shouldn't be flooding the room with light. It just seems like pitch black is a bit extreme when the outside is so radiant.

It really does seem like my sunlight hits a single surface, and then stops dead (except if I use that one material from the lightroom, I can't explain why that seems to work fine. Other materials, including white ones, don't reflect at all). If I build a room with plenty of windows, any shadows will still be pitch black. Surely that can't be right?

avatar image Kibblesticks Jul 22 '17 at 02:05 PM

The "first answer" thing was because you asked if I could convert my comment into an answer. I was just shortening the answer.

Have you opened the working material to see what it does differently? I guess roughness or specular might have something to do with it but I don't know. The materials in the working room certainly looked like they had a low roughness.

Pretty easy way to check lighting would be to delete a wall and see if the problem persists. If so there's something else going on, but I suspect it's building lighting realistically and it doesn't matter how much light is outside if it can only enter through three/six small holes.

There's definitely bouncing going on it that room so maybe crank up the intensity on your skylight (not directional) and see if that helps.

The angle of your directional light will have an effect too. Right now it looks like it's missing the windows so any light coming in will be minimised. You could point the directional light so it's shooting rays right directly into the room and hitting one of the surfaces inside.

avatar image Seadevil Whiskey Jul 22 '17 at 02:49 PM

Firstly, thank you for keeping coming back with suggestions. Tearing my hair out over this and I appreciate the assistance.

I'm afraid I haven't learned much about materials yet, so I'm not sure how I'd check, but here's a picture of the settings I could find. alt text

Having an entire side open leaves me with this. Looks way too dark to me personally, considering both "indirect lighting" scales are set to max. alt text Cranking up the intensity does begin lighting up my room, but leaves the outside totally washed out. You can see in the lightroom next door it's bleached everything. alt text alt text

2.png (1.2 MB)
1.png (1.5 MB)
3.png (1.5 MB)
4.png (674.3 kB)
avatar image Kibblesticks Jul 24 '17 at 01:27 PM

A roughness of 1 means the lowest reflection possible. 0 roughness would be a mirror. Set the roughness values to 0 and see if it has any effect. Then tweak them upwards till you get the desired result.

As an aside, if you're getting into visualisation or level design, materials are very simple to learn and super useful to know in UE4. There's a great playlist on Youtube you could use to learn them in a single day (it's how I learnt them): UE4 Material Tutorial Playlist

For this specific problem I recommend the videos "Basic Materials" and "Instanced Materials". Should give you the info you need to adjust the materials in your existing project.

avatar image Seadevil Whiskey Jul 24 '17 at 08:46 PM

Thanks for the info!

So having put in some large windows, covered the walls and floor with a '0 roughness' material, and set the directional and sky light to default, I'm left with this. Shouldn't the inside be bathed in light? alt text alt text

1.png (646.8 kB)
2.png (680.0 kB)
avatar image rasamaya Dec 13 '18 at 06:48 PM

Have you tried applying luts and bringing up the exposure on the camera? try 2 instead of 0. zero isnt well suited for interiors. Also lightmass resolution on specific objects could be low.

avatar image Kibblesticks Jul 25 '17 at 10:34 AM

I'm afraid I don't have any answers beyond this point. I think you're just going to have to tweak settings till you get the desired result. Increase "Indirect lighting" in your directional light, and maybe up the intensity and indirect lighting of your sky light.

I also don't know if fog has any effect on static lighting so maybe check the original scene to see if there was an "exponential height fog" or "atmospheric fog" in there.

Finally, I imagine the original scene had a custom "post process volume" so copy that over too. Or create your own PPP and set the highest and lowest values in the auto-exposure tab to the same number (1 or 2), and then find the "unbound" checkbox at the bottom and tick it, so the volume effects your whole scene.

I think it'll just be a case of finding settings to tweak so I'm going to leave it there with the answers. For more info google "UE4 bounce lighting". There's some similar questions been asked that might help.

avatar image Seadevil Whiskey Jul 25 '17 at 10:39 AM

The problem is that the "indirect lighting" scales don't actually seem to do anything for me. It's why I'm worried my install might be bugged somehow.

Still, thank you for your help, I'll continue playing around and hopefully I'll figure out the problem eventually.

Cheers.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question