x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Audio Attenuation is broken on sequencer sounds attached directly to level actors

I use a lot of soundcues in the sequencer editor which are attached directly to level actors (in order to follow them for proper real time spatialization in VR). This method is outlined in UE4 sequencer documentation and has always worked great on 4.12-4.14 versions.

Just moved from 4.14 to 4.16, and now the volume attenuation of these sequencer soundcues seems completely broken. After doing a lot of testing, the attenuation settings no longer affect sounds in the sequencer which are attached to actors. Basically it sounds like there is a fixed radius & falloff distance amount for whatever sounds have been attached directly to a level actor. I no longer have any attenuation control over 95% of the sounds in our project which exist inside the sequencer editor.

I have a lot of sounds setup with very short attenuation distances (so you only hear them when you are next to the source), and immediately after upgrading to 4.16 I noticed you could now hear these sounds from VERY far away. I went in and tried adjusting the attenuation settings, but adjusting these seems to make no difference on the volume attenuation falloff.

When I attach the same sounds to an ambient sound source (outside of the sequencer), attenuation works properly, as it always has for me. For some reason it just seems using the sequencer editor actor-attach method now breaks the volume attenuation completely.

While it mainly affected the short-attenuation distance sounds I had setup, it also greatly affects the sounds with long attenuation distances, since some characters are coming in from afar. No matter how large falloff distance number I set, I still cant hear the sound past a certain point. It really sounds like the attenuation file is being bypassed completely and is defaulting to some reasonable large numbers, regardless of what changes you make to the attenuation file.

Really need help with this as it has completely broken the audio setup in our project.

Product Version: UE 4.16
Tags:
more ▼

asked Jul 21 '17 at 09:57 PM in Bug Reports

avatar image

danp212
1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Can you try with the 4.17 preview? I believe we fixed this issue.

more ▼

answered Jul 21 '17 at 10:03 PM

avatar image

Max.Chen STAFF
2.3k 28 14 68

avatar image danp212 Jul 21 '17 at 11:38 PM

confirmed fixed in 4.17 preview 2, do you have a changelist # for that?

avatar image Max.Chen STAFF Jul 22 '17 at 12:21 AM

I believe it's CL#3407794.

There's some more audio changes in 4.17, so if that's not it let me know.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question