x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor crashes when opening blueprint that uses C++ Enum

Hello!

Note: reverting changes doesn't solve the issue

My code contains blueprints and a couple of functions and enums in C++. I moved around my C++ code, and now, when I'm trying to open those blueprints that used C++ enums, editor crashed. I can use the C++ functions in my new blueprints, but cannot open old ones that use them. I didn't make any changes to C++ code or blueprints, just renamed C++ files (tried to revert all those changes back, didn't help). I also tried to migrate code to a fresh project; same issue. I suppose the issue is that Unreal looks up a reference to a C++ class and can't find it. I have no idea how to restore the references.

I'd be happy with any sort of solution, such as going through every occurrence of the C++ enums and replacing them with new references, or having those nodes removed, anything that would let me open my blueprints :(

Just in case, here's the crash log:

 LoginId:8f0a5ac7407a475fa96a178a8e69306b
 EpicAccountId:3f19310edced4ab1be3aea7dd7ef303e
 
 Access violation - code c0000005 (first/second chance not available)
 
 UE4Editor_CoreUObject!FPropertyTag::FPropertyTag() [d:\build\++ue4+release-4.15+compile\sync\engine\source\runtime\coreuobject\private\uobject\propertytag.cpp:58]
 UE4Editor_CoreUObject!UStruct::SerializeTaggedProperties() [d:\build\++ue4+release-4.15+compile\sync\engine\source\runtime\coreuobject\private\uobject\class.cpp:1165]
 UE4Editor_CoreUObject!UObject::SerializeScriptProperties() [d:\build\++ue4+release-4.15+compile\sync\engine\source\runtime\coreuobject\private\uobject\obj.cpp:1155]

full log: https://pastebin.com/R2g9mHsi

Product Version: UE 4.15
Tags:
more ▼

asked Jul 22 '17 at 08:47 PM in Blueprint Scripting

avatar image

chriskcreates
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question