Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error when compiling with Ultimate Mobile Kit (plugin) for Android


Our team is currently creating an Android game, everything works perfectly, except one thing, a plugin. Ultimate Mobile Kit (1.3.0), which seems to be really good, after all, we need it. :) But, when we're compiling with the plugin, everythings goes wrong...

 UATHelper: Packaging (Android (All)): UnrealBuildTool: C:/NVPACK/android-ndk-r12b/toolchains/arm-linux-androideabi-4.9/prebuilt/windows-x86_64/lib/gcc/arm-linux-androideabi/4.9.x/../../../../arm-linux-androideabi/bin\ld: error: cannot find -lapp
 A:\Projects\Unreal Engine\DriimCpp\Plugins\UltimateMobileKit\Source\UltimateMobileKit\Private\App/FirebaseApp.cpp:105: error: undefined reference to 'google_play_services::CheckAvailability(_JNIEnv*, _jobject*)'
 A:\Projects\Unreal Engine\DriimCpp\Plugins\UltimateMobileKit\Source\UltimateMobileKit\Private\App/FirebaseApp.cpp:105: error: undefined reference to 'google_play_services::CheckAvailability(_JNIEnv*, _jobject*)'
 A:\Projects\Unreal Engine\DriimCpp\Plugins\UltimateMobileKit\Source\UltimateMobileKit\Private\App/AppMakeGooglePlayAvailable.cpp:32: error: undefined reference to 'google_play_services::MakeAvailable(_JNIEnv*, _jobject*)'
 A:\Projects\Unreal Engine\DriimCpp\Plugins\UltimateMobileKit\Source\UltimateMobileKit\Private\App/FirebaseApp.cpp:50: error: undefined reference to 'firebase::App::Create(firebase::AppOptions const&, _JNIEnv*, _jobject*)'
 Runtime/Core/Public\Templates/SharedPointerInternals.h:158: error: undefined reference to 'firebase::App::~App()'
 clang++.exe: error: linker command failed with exit code 1 (use -v to see invocation)
 ERROR: UBT ERROR: Failed to produce item: A:\Projects\Unreal Engine\DriimCpp\Binaries\Android\DriimCpp-armv7-es2.so

I know what the error means, it's not that (hope undefined reference that appears after are caused by lapp). I already check on other topics of people getting similar error "cannot find -". But I can't make it work for lapp. Our game is being developed in Unreal Engine 4.16 (launcher version). When I saw people building from sources, I did the same, but got the error too. When I tried building from sources, I used the setup.bat with --all to be sure. But it's the same. We've got Codeworks 1R6u1 with sdk 25.2.3. As I already said, the compilation works without the plugin... :( Tried with android-ndk pathing to 15, 12, 10...

And try to change NDK api to 19 and SDK to matchndk, but did not work either... I feel like a dead end... >.<

At the bottom, with attachments, you'll find our Logs, with UnrealBuildTool logs too and screenshots for plugins and android sdk page in Settings.

Is it only related to the plugin (so, do I need to contact the dev?) or some dependencies are missing? It's been almost two days since I hope to make it works :(... If you need more information to help us, don't hesitate! I'll reply as soon as possible. Thanks.

Thanks in advance for your help,

Cheers, Matthieu "Sworyz".

alt text

alt text

Editor Logs

Unreal Build Tools Logs

Product Version: UE 4.16
more ▼

asked Jul 28 '17 at 08:33 PM in Packaging & Deployment

avatar image

3 1 3

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Sworyz,

Can you check if the make files are configured properly ? If the linker is not able to find certain libraries then the paths to those libraries should be added in the Make files. I don't remember if you need to do this in the Android.mk or Application.mk, but making the changes to on of those files will help.

Let me know if this does not help.

Thanks d0d0

more ▼

answered Jul 31 '17 at 08:05 PM

avatar image

477 16 8 18

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question