x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Light Bleeding when using a single floor for many rooms

Hello everyone,

I'm experimenting with lightmaps and there is one artefact I don't understand. It looks like at some point it doesn't matter how many pixels to put between UV shells or how high the lightmap resolution is - the light bleeds anyway. Not sure whether it's me doing something wrong, a bug or just how lightmaps work so any help will be appreciated.

I've prepared a simple project to showcase the artifact. There are 2 maps in the project:

  1. MAP_Floor_Solid map has the light bleeding at the bottom of the walls. The floor is a mesh with two separated geometry pieces and one UV map that has 2 UV shells snapped to the pixels (one UV shell per geometry piece).

  2. MAP_Floor_Separated is what I'm trying to achieve. There is no bleeding. The floor consists of two separated meshes and each mesh has its own UV map.

It feels like the indirect lighting stops to care about the walls or uv-shells at some point.

The solutions I've found so far:

  1. Use a separate floor per room. This way it's possible to completely remove the light bleeding but the final result is not that good because of a different shading between modular floor pieces. More can be found here: LightingTroubleshootingGuide: Shadow Seams/Shading Differences with Indirect Lighting

  2. Adjust the Lightmass Settings. The most useful parameters are: Static Lighting Level Scale, Indirect Lighting Quality, Indirect Lighting Smoothness. The floor looks great, no seams and shadow differences but it's kind of hit & miss to find balance between good looking shadows and no light leaks. Also it's quite likely that the Lightmass settings has to be adjusted each time adding a new light to a scene because the new light can cause more bleeding.

Is there something else to look at? It would be great to get a robust solution with the solid floor as it's done with the modular geometry.

Thanks.

P.S. The blend & fbx files can be found here: UE4Tests/Assets/Blender.

Product Version: UE 4.16
Tags:
more ▼

asked Aug 01 '17 at 10:57 AM in Rendering

avatar image

visualcortex
1 2

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question