x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Adding a C++ class doesn't seem to be recognised in editor

Hey all,

If I try and add a C++ class to my project, it says it successfully creates one and is visible in the projects source folder, however it says the module needs to be recompiled for it to be seen in the content browser.

When I then re-open the project I get the message saying the 'projectname.dll was built for a different version, would you like to rebuild it?', if I click yes it says it fails and I should try rebuilding from source manually.

If I go to generate the Visual Studio Project Files, I get an error and the only way I can open my project again is I have to delete the Intermediate and Saved, then open it. I can then generate the VS files.

If I build from source, the C++ class still doesn't appear in the content browser though.

This seems to happen with every project too. I'm using Unreal 4.15.3 and Visual Studio 2015.

Thanks

Product Version: UE 4.15
Tags:
more ▼

asked Aug 04 '17 at 08:55 AM in C++ Programming

avatar image

M.wmmn
145 6 6 12

avatar image mightyenigma Dec 29 '17 at 12:43 AM

I tried to add a C++ Actor to my Blueprint project and got the same problem in 4.17.2 (Visual Studio 2015 selected as compiler). However, removing the Intermediate and Saved folders fixed the problem for me! So... thanks for helping me with MY problem. Hope you figure yours out, soon.

avatar image M.wmmn Mar 07 '18 at 11:15 AM

Haha you're welcome :)

avatar image Atheist91 Mar 07 '18 at 12:40 PM

Hey.

In the end you were able to compile and run the project right? If so, what is a parent of your class?

avatar image Cabewz Mar 08 '18 at 07:57 PM

Try deleting all generated folders in your project directory. For example, .vs, Binaries, Intermediate, Saved, Source. I know you said you tried with just Saved and Intermediate but I have had a similar error before where I needed to delete all folders and then I could rebuild. I see that you are using Visual Studio 2015, you could try upgrading to 2017 if the problem persists. I wouldn't think that would be a problem but who knows.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question