x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UnrealBuildTool fails with null argument

After upgrading my project to 4.17 it's started occasionally failing to compile because UnrealBuildTool encounters a System.ArgumentNullException when it tries to run. The full callstack is:

 2>EXEC : error : System.ArgumentNullException: Value cannot be null.
 2>  Parameter name: source
 2>     at System.Linq.Enumerable.Any[TSource](IEnumerable`1 source, Func`2 predicate)
 2>     at UnrealBuildTool.ExternalExecution.ExecuteHeaderToolIfNecessary(BuildConfiguration BuildConfiguration, UEBuildTarget Target, CppCompileEnvironment GlobalCompileEnvironment, List`1 UObjectModules, FileReference ModuleInfoFileName, ECompilationResult& UHTResult)
 2>     at UnrealBuildTool.UnrealBuildTool.RunUBT(BuildConfiguration BuildConfiguration, String[] Arguments, FileReference ProjectFile)

I don't recall encountering this error while testing the preview but that may have simply been luck since I didn't do more than occasionally make sure all my code still compiled and ran. Doing a full rebuild of my project fixes the error but I'd like to avoid having to do that if possible since it usually takes a few minutes.

Product Version: UE 4.17
Tags:
more ▼

asked Aug 08 '17 at 04:19 PM in Bug Reports

avatar image

kgamble
934 44 62 211

avatar image kgamble Aug 08 '17 at 08:02 PM

Further testing finds that this only occurs when I change a header file. I made a new (blank) code project and encounter the exact same issue and tried it on a different machine so it doesn't seem to be an issue with either my project or computer.

avatar image RoyAwesome Aug 09 '17 at 02:22 AM

I'm also having this issue when changing a header.

avatar image Gnometech Aug 11 '17 at 03:20 PM

Adding my own voice to this. Added two transient properties to a class header, and was hit by this exact build error. Clean and rebuild got me past it.

avatar image Büke Sep 23 '17 at 06:58 AM

Same error, when changing a .h file with UE 4.18p1.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Have you tried this fix by Ben Marsh from Epic?

I was facing similar issue,this has solved my problem.

I hope that,it helps you.

Link to forum post by Ben

more ▼

answered Aug 11 '17 at 05:59 PM

avatar image

Superflare
130 6 7 15

avatar image kgamble Aug 11 '17 at 06:17 PM

Yep, that did it. Didn't think to check that part of the forums so thanks for the link.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It's not a fix, but if you regenerate project files you can compile again.

more ▼

answered Aug 09 '17 at 03:29 AM

avatar image

RoyAwesome
11 2 4 7

avatar image DaGaffer Aug 09 '17 at 08:27 PM

I'm having the same issue.

The workaround I've used is to Rebuild/build clean - works as well.

avatar image ZABBA_THE_HUT Aug 10 '17 at 12:24 PM

I have the same issue after updating to 4.17. I can confirm that both workarounds work, but it is quite cumbersome and time consuming to rebuild every time.

Best

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question