x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

iOS In-App purchases on TestFlight come back as "Not Allowed".

Hello,

We are currently finishing up a mobile app that is going on iOS App Store and Google Play. But, we are having an issue with the in-app purchasing. The project was compiled and submitted to TestFlight successfully. When pressing the button to make the in-app purchase we are given a status of, " Unknown", then when pressed again we receive, "Not Allowed". We have been researching and looking at forums for about 3 weeks now, and tried nearly everything we can muster. If anyone has a suggestion we would deeply appreciate it.

Product Version: UE 4.14
Tags:
more ▼

asked Aug 09 '17 at 01:23 AM in Everything Else

avatar image

TheWazz
11 1 3 4

avatar image TheWazz Aug 14 '17 at 08:59 PM

We had just created a blank project with IAP buttons and new provisions and still get the same problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I'm not sure if this is the same issue, but I had the same error message and what I found that ended up fixing the problem was to modify the IOS.ini config file within the project. By default the bUsesStoreV2 is set to True; however, if you set this to False, and make sure everything is set up correctly in iTunes Connect, then it should work.

debug2.jpg (772.5 kB)
more ▼

answered Aug 09 '17 at 08:25 PM

avatar image

thejus75
6 2 4

avatar image thejus75 Aug 09 '17 at 08:31 PM

Alternatively, you can view the file for yourself or copy and paste it into your config folder.

ios.zip (811 B)
avatar image TheWazz Aug 09 '17 at 09:03 PM

We just tried what you have recommended and set it to false and still receive the same error.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was able to fix the issue of getting "Not allowed" in a TestFlight build by setting bUsesStoreV2 to false in IOSEngine.ini, and I also made sure to have the same settings in IOSEngine.ini, and the same modules included in my game's Build.cs file, as what is in Epic's Unreal Match 3 source code. You can download the Unreal Match 3 source code by searching for "Match 3" in the Learn tab in the Epic Launcher.

Unreal Match 3 is an iOS and Android game Epic made as a learning resource, and it includes examples of IAPs, Leaderboards, and Achievements.

more ▼

answered Sep 18 '17 at 08:49 PM

avatar image

JonathanADaley
644 37 49 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question