x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Random Crashes

I'm new to UE4, in fact I installed only a couple of days ago, but I can't do much in it unfortunately, it crashes randomly after some time. Sometimes after 10 seconds, sometimes after 3 minutes. Doesn't matter whether I'm opening the saved project (still empty) or creating a new one, the crash is inevitable. I don't think it's related to any specific setting, shape or anything I add, because sometimes it crashes when I click on a menu, sometimes when I move the camera, sometimes I just wait and it crashes anyway.

LoginId:c2a2d06c4514b900622238aff98bc029 EpicAccountId:0ca3a919d5e24a3d95397ec241c5932a

Fatal error: [File:D:\Build\++UE4+Release-4.17+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 182] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0020 - 'INTERNAL_ERROR')

UE4Editor_Core!FDebug::AssertFailed() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:349] UE4Editor_D3D11RHI!TerminateOnDeviceRemoved() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:192] UE4Editor_D3D11RHI!VerifyD3D11Result() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:231] UE4Editor_D3D11RHI!FD3D11Viewport::PresentChecked() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:289] UE4Editor_D3D11RHI!FD3D11Viewport::Present() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:472] UE4Editor_D3D11RHI!FD3D11DynamicRHI::RHIEndDrawingViewport() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:591] UE4Editor_RHI!FRHICommandList::EndDrawingViewport() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\rhi\private\rhicommandlist.cpp:1399] UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::DrawWindow_RenderThread() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:876] UE4Editor_SlateRHIRenderer!TGraphTask > >::ExecuteTask() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\core\public\async\taskgraphinterfaces.h:784] UE4Editor_Core!FNamedTaskThread::ProcessTasksNamedThread() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\core\private\async\taskgraph.cpp:650] UE4Editor_Core!FNamedTaskThread::ProcessTasksUntilQuit() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\core\private\async\taskgraph.cpp:559] UE4Editor_RenderCore!RenderingThreadMain() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:325] UE4Editor_RenderCore!FRenderingThread::Run() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:459] UE4Editor_Core!FRunnableThreadWin::Run() [d:\build++ue4+release-4.17+compile\sync\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:76]

This is the crash report I'm getting. And here is my DxDiag file. I'm on laptop. Can you help me please? I have no idea what to do with it. Thanks! link text

Product Version: UE 4.17
Tags:
dxdiag.txt (104.9 kB)
more ▼

asked Aug 15 '17 at 09:08 AM in Using UE4

avatar image

LouJJ
16 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello! You can read about your error in this other post, you have aswell there a solution: https://answers.unrealengine.com/questions/539008/unreal-engine-is-exiting-due-to-d3d-device-being-l-1.html

more ▼

answered Aug 15 '17 at 03:03 PM

avatar image

vorixo
326 2 6 13

avatar image LouJJ Aug 15 '17 at 06:12 PM

Thanks for replying, I read myself through the comments but I noticed that the error code is different than mine in this report despite the same error message. Anyway I tried the Editor after installing the mentioned patch and it did make a little difference. Unfortunately the crash still happens randomly but now in much bigger time intervals. I have like 3-5 minutes.

avatar image vorixo Aug 15 '17 at 06:46 PM

It may be aswell a cause of a faulty hardware,

avatar image LouJJ Aug 15 '17 at 07:18 PM

I've been using Unity Engine on this laptop for two years now and never had any problem with that or any other software. I'm going to run a full memory test tomorrow just in case but the last time I did it was fine. Any other idea perhaps? Thank you

avatar image vorixo Aug 15 '17 at 07:40 PM

We are still investigating this d3d hung crash issue. If none of the suggested work arounds assist you I would suggest working in a previous engine version that doesn't have issues.

I would suggest of keep track of the error on this other post: https://answers.unrealengine.com/questions/545292/unreal-engine-is-exiting-due-to-d3d-device-being-l-3.html

I suggest you aswell to copy your version of the error there.

avatar image LouJJ Aug 16 '17 at 06:33 AM

okay. Now I'm sure the hardware is fine. I'd like to revert UE back to an earlier version but which one would you suggest? There are quite a few. Thanks

avatar image vorixo Aug 16 '17 at 09:42 AM

You can try with 4.15 or 4.14 ~

avatar image LouJJ Aug 16 '17 at 04:43 PM

I tried 4.13. It was working fine until I dragged one chair object into the scene from the built-in assets. Then it froze and crashed. Same thing again and again unfortunately. I give up.... But thanks for your help anyway! Have a great day!

avatar image LouJJ Aug 17 '17 at 07:38 AM

I noticed something important. It turns out that is runs with the integrated Intel video card and not with the much better Radeon dedicated one. I tried everything to make it use the dedicated one without success so far. There's no disable option in Bios either. Is there a parameter you can start UE with to define which display processor to run with? Thanks

avatar image LouJJ Aug 18 '17 at 09:27 AM

Update: After having tried all of the UE versions and experienced the same crash, I finally managed to solve the "D3D device being lost" issue by setting the FPS limit to 30 instead of the default 60. In the "...Program Files\Epic Games\UE_4.17\Engine\Config\ConsoleVariables.ini" file, after the [Startup] line I put: t.maxfps = 30

And now it is working fine, no matter what I do, can't replicate the previous crash issue. If anyone is having the same problem, give this a try. It worked for me. Cheers

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question