x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

'Failed debugging check' when remote build for Distribution via Project Launcher

When attempting to use the Project Launcher to package a project for distribution via remote build to a Macbook, the intended provision file is not used; instead it is rejected with the following message:

UnrealBuildTool: .. Failed debugging check (mode=False, get-task-allow=False, #devices=0)

However, get-task-allow has to be false in order for a project to be packaged for distribution for iOS.

Other relevant lines include:

Automation.ParseCommandLine: Parsing command line: -ScriptsForProject=D:/AppleBuild4.17/AppleBuild.uproject BuildCookRun -project=D:/AppleBuild4.17/AppleBuild.uproject -noP4 -clientconfig=Shipping -serverconfig=Shipping -nocompile -nocompileeditor -installed -ue4exe=UE4Editor-Cmd.exe -utf8output -platform=IOS -build -cook -map= -unversionedcookedcontent -pak -createreleaseversion=1.0 -manifests -distribution -stage -package -cmdline=" -Messaging" -addcmdline="-SessionId=D3ADC44A456F475A251E2EB1140BB5CC -SessionOwner='Lucian' -SessionName='AppleBuild - IOS App'" -archive -archivedirectory=C:/Users/Lucian/Desktop/4.17Test/IOS/App/1.0

And:

CommandUtils.Run: Run: D:\Program Files\Epic Games\UE_4.17\Engine\Binaries\DotNET\UnrealBuildTool.exe AppleBuild IOS Shipping -Project=D:\AppleBuild4.17\AppleBuild.uproject D:\AppleBuild4.17\AppleBuild.uproject -NoUBTMakefiles -remoteini="D:\AppleBuild4.17" -skipdeploy -noxge -NoHotReload -ignorejunk

Attached is the log: Log of ProjectLauncher

As far as I can determine, UE4 is attempting to produce a development copy for Xcode despite all options indicating this is to be for distribution. Or is get-task-allow=True necessary for Xcode to even deal with the file in the first place?

Any insight into this would be appreciated. Thanks.

Product Version: UE 4.17
Tags:
more ▼

asked Aug 15 '17 at 10:29 AM in Packaging & Deployment

avatar image

thespeech
56 2 10

avatar image thespeech Aug 23 '17 at 09:53 AM

Update to this: I never got it to work, it still thinks that having get-task-allow=False is a crime that doesn't allow that provisioning profile to be used despite it being the desired one, and still tries to select development profiles. If I remove all the other provisioning profiles except the distribution provisioning profile and certificate, it rejects the distribution profile nevertheless and falls back to a default UE4Game.provision. I replaced that default provision with the distribution provision, and this time it actually got all the way to the Mac, but then failed when it could not find an 'iOS Development' key to sign the application with (it should be trying to find 'iOS Distribution').

In the end I set it to Shipping configuration, built it with the development certificates, then resigned it with the distribution certificates on the Mac using iResign. It at least gets onto TestFlight and runs on at least one test device, but I'm not sure if that holds for it making it onto the App Store proper.

avatar image pyr0t0n Sep 26 '17 at 09:57 AM

You are not alone, we are facing the same problem. UE always uses the developement mobile provisioning file and want's the related certificate. Never mind if it is a shipping build, flagged for distribution.

avatar image 一桶姜山 Oct 31 '17 at 01:33 AM

Well,I'm facing this problem too. Let me join you waiting for someone to figure it out.

avatar image BNC Nov 03 '17 at 03:01 PM

same here...

avatar image Antidamage Jan 13 '18 at 08:43 AM

Likewise, me too thanks, etc. Has anyone successfully built a UE game for distribution on iOS?

I'm building on a Mac, so the remote build thing isn't part of the problem.

avatar image Devator Nov 15 '17 at 11:51 PM

Same issue here...

avatar image Shaisa Dec 28 '17 at 11:49 AM

Same here... When uploading this signed version, it doesn't "behave" in TestFlight as in Development deployment. It doesn't request the permissions (camera and notifications) and it's stuck on the splash screen.

Tried the stuff on this thread, also with no change: https://forums.developer.apple.com/thread/86161

avatar image wzspdw Apr 02 '18 at 03:16 PM

Same issue here...

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I got an answer from UE devs concerning the distribution issues so I'll paste it here:


It is HIGHLY recommended that any build being uploaded to iTunes be built on a Mac and not over the remote build system. Not only is there this bug, but none of the metal shaders will be offline compiled which will cause stutters when a material is first used as it will need to compile the shader then.

And:

The workaround is to make sure the development certificate and provision are on the remote mac. It will use the development certificate when doing the build, and then when it signs on the PC it will re-make the entitlements and sign it with the distribution certificate.


They also said that the underlying issue for distribution on remote build is being fixed for 4.19 but after going through QA it's still not completely fixed.

These are actually good enough reasons for me to switch to Mac for distributing iOS apps (it'll maybe also solve other issues with packaging size/features).

more ▼

answered Jan 09 '18 at 04:12 PM

avatar image

Shaisa
56 3 4

avatar image Antidamage Jan 13 '18 at 08:44 AM

I'm building on a Mac and I still have this problem. I'm most likely missing something but I cannot get UE to package and sign a distribution build for iOS using distribution certs. It will always fail over get-task-allow.

I worry that I'll have to package and then re-sign it with XCode and I'm not really a mac developer, so the whole process is a bit arcane.

avatar image Shaisa Jan 13 '18 at 11:20 AM

Are you doing package using File > Package Project > iOS, or trying to package from the Launch > ? Just in case you use the latter, that one will fail from that reason. The former should work (assuming everything is in place).

(comments are locked)
10|2000 characters needed characters left

Hi, as I stated in my second post, I never got this process to work BUT I had a workaround in the form of packaging for development using the development certificate first, then resigning the resulting ipa using the actual distribution certificate on the Mac using iResign. So if you just want to push it out without moving the whole project over to Mac, you can try that method.

more ▼

answered Jan 13 '18 at 11:58 AM

avatar image

thespeech
56 2 10

avatar image Shaisa Jan 13 '18 at 12:00 PM

Yeah. That could work. Depending on the app though. Mine had some features not working when using this workflow... But if it works, then great.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question