x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Building lighting stuck at 0%

Hello,

I just created a new project, an empty project. I placed directional light and sky light. I created a standart 2x2 landscape.I pressed build and it got stuck at: Building lighting 0%. I tried it again a couple times but it didn't work. I restarted my pc and deleted the project, I did the exact same things and it got stuck again.

Please help me.

Greetings Robin

Product Version: UE 4.17
Tags:
more ▼

asked Aug 16 '17 at 05:31 PM in Using UE4

avatar image

So_Robro
1 1 2 2

avatar image janimationd Aug 16 '17 at 06:08 PM

Did your editor freeze, crash, or was it just taking a while for progress to be made?

avatar image So_Robro Aug 16 '17 at 08:10 PM

It didn't freeze or crash. It stayed on 0% for a long time and after that it said: Build lighting failed.

avatar image Betazero Aug 26 '17 at 03:15 PM

I am having this problem since about 4.15 I think. I was able to build no problem before that but now it does 0% then fails. I just deleted all assets from my scene except the player, a directional light and a ground static mesh and it still fails. Every map I have in the project I am working on. I have opened other projects and it builds. I have tried firewall on firewall off.....deleting sworm cache ....deleting saved and intermediate folders..... all I get is:

LogStaticLightingSystem:Warning: Failed to build lighting!!! Lighting build failed. DumpUnbuiltLightIteractions Lights with unbuilt interactions: 0 Primitives with unbuilt interactions: 0

Not sure what to do. I have like a years worth of work and I can't build the lights... :(

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Close the editor and delete (or rename) the folder "Saved" from your project.

For example: "C:\Users\[user_name]\Documents\Unreal Projects\[project_name]\Saved"

Then open it back up and rebuild your lighting.

more ▼

answered Aug 16 '17 at 08:11 PM

avatar image

Andrei Despinoiu
250 4 9 12

avatar image BobbyF Sep 05 '17 at 05:39 PM

I just wanted to post a reply stating this workaround fixed the issue for me.

I simply renamed the "saved" folder to "saved_1" I then opened up the Unreal Engine Project file, The engine created a new "Saved" folder inside my project root folder. I jumped back into the editor and Pressed build and the editor started building my scene immediately.

I also want to mention I am currently using engine version 4.17.1 Thank you @Andrei Despinoiu

avatar image PurrPaw Aug 25 '18 at 05:30 PM

That has fixed it for me too! Thanks alot.

avatar image BillowInPacific Feb 05 '19 at 10:14 PM

Thanks a lot. I had the same problems. Solved after deleting "saved" folder.

(comments are locked)
10|2000 characters needed characters left

double click on your mesh and on the right you will see light map resolution, reduce the light map resolution on the mesh, 1024 is a good quality anything above could stall the light building causing 0% for a very long time. if this is still causing you problems, go thru all your meshes you've added to your map and reduce them all.

more ▼

answered Sep 18 '18 at 08:31 PM

avatar image

GhettoDJ
1

(comments are locked)
10|2000 characters needed characters left

I deleted my save folder and tried it again and it's still taking forever... I feel like giving up lol

more ▼

answered Mar 29 '19 at 05:42 AM

avatar image

peanutbutterJedi
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question