x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Fail to compile latest "master" source

I get the following error's when trying the latest Master source (with commits of today) I'm a bit lost here as it's just a fresh pull from github with the 2 dependencies files included and extracted.

Error 2 error : Failed to produce item: D:\DO_NOT_ARGUE\GAMES\UE4\SOURCE\master\Engine\Binaries\Win64\UnrealHeaderTool-Core.dll D:\DO_NOT_ARGUE\GAMES\UE4\SOURCE\master\Engine\Intermediate\ProjectFiles\ERROR UE4 Error 1 error LNK1181: cannot open input file 'zlib_64.lib' D:\DO_NOT_ARGUE\GAMES\UE4\SOURCE\master\Engine\Intermediate\ProjectFiles\LINK UE4 Error 3 error MSB3073: The command "....\Build\BatchFiles\Rebuild.bat UE4Editor Win64 Development" exited with code 2. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets 43 5 UE4

Product Version: Not Selected
Tags:
more ▼

asked Jul 11 '14 at 04:07 PM in C++ Programming

avatar image

KillerSneak
151 10 12 17

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi KillerSneak,

I suspect that the solution to this issue will be similar to your other question about 4.3, but it would be best to approach it as a separate issue.

What method were you using to download the Master source? Were you synching your repository to the Master branch or downloading the zipped file? If you were downloading the zipped file, what GitHub page were you getting it from?

I did notice one page for the Master branch appeared to be linking to dependency files for version 4.1, so those dependency files will actually not work when trying to build the Master branch. I will see if I can get those links updated.

Keep in mind that the Master branch (and any preview branches) are not always fully tested and can potentially be unstable. They are great for getting a sneak peek at new features and capabilities, or for checking for fixes to issues that you may have run into, but I would not recommend using them for actual development.

more ▼

answered Jul 11 '14 at 09:12 PM

avatar image

Tim C ♦♦ STAFF
18.1k 423 69 286

avatar image KillerSneak Jul 12 '14 at 11:12 AM

Hi Tim,

I have the Master branch synced with TortoiseSVN so I can get the latest build/branch when ever I need to. The dependencies for Master I got from this page as described, https://github.com/EpicGames/UnrealEngine/tree/master #1 - https://github.com/EpicGames/UnrealEngine/releases/download/4.1.0-release/Required_1of2.zip #2 -https://github.com/EpicGames/UnrealEngine/releases/download/4.1.0-release/Required_2of2.zip

I'm sure i got the right dependencies as you can see from the links above.

Please correct me if I did anything wrong.

avatar image Tim C ♦♦ STAFF Jul 14 '14 at 09:24 PM

Hi KillerSneak,

Sorry for not replying earlier today. The links that you mention are actually the ones I mentioned above that are linking to the dependencies for 4.1. I have already reported that error and it should be corrected soon.

To get the correct dependencies for the Master branch, you can visit this page. I tested these using the zipped source code (also available on that page) and it built fine for me. The zipped source code on this page is not a live update, so it may be a few days behind the actual Master branch in the repository. I do not currently have a repository synced to the Master branch, but if the dependencies on the page I linked here don't work, I can sync one and see if the branch itself may currently be unstable.

avatar image Tim C ♦♦ STAFF Jul 15 '14 at 05:05 PM

This morning I completely removed my local UE4 repository and started over using a fresh fork from the Unreal Engine repository. I tried building the Master branch using the dependencies that I linked above, and ran into a linker error. I believe this is because the dependencies are approximately a week old, while the Master branch is current up to about two hours ago. Since the dependencies are not updated as frequently as the Master branch, these discrepancies can happen occasionally.

(comments are locked)
10|2000 characters needed characters left

I had that problem (cant open zlib_64.lib) havent extracted the second of the required packages.

I deal all the times with split packages so i thought it would extract both packages with just extracting the first. No error from the generate project files but i got the error for cant open zlib_64.lib when trying to build.

Its an easy made mistake that took me a good nights sleep to realize. Because build error aggrevate me ;D

So make sure u extract both packages one at a time and of course in the right folder /engine to engine (so the content of engine goes into engine and not engine into engine!) and the other 2 side by side to engine folder not in it.

more ▼

answered Aug 19 '14 at 03:32 PM

avatar image

Spaehling
163 7 14 22

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question