x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Physics Actor dropping to ground when attached to character

in 4.2.1 - I had a Dinosaur character with a separate tongue skeletal mesh/physics body.

I attached them together using a physics constraint in the component section of the blueprint. This worked perfectly. The dinosaur could run forward and the tongue would follow, simulating physics too. It acts as one solid mesh, following animations etc.

In 4.3 - 4.5.1 , the tongue instantly snaps to the origin of the character and does not follow. This is using the exact same settings as 4.2.1

I have tried workarounds, such as using the "Attach to" node via the construction script, which showed the same results. I also tried the same thing but via the event graph instead - same behavior.

Product Version: Not Selected
Tags:
more ▼

asked Jul 12 '14 at 04:16 AM in Bug Reports

avatar image

Kenomica
434 40 40 46

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hello, Kenomica!

We've found this bug on our end, too, and we're working on it. We've got a fix, and the fix should be in the official 4.3 release - if you find that this bug is still happening, then please post again and we'll take another look at it.

Thanks for your patience,

Jonathan Dorman

more ▼

answered Jul 15 '14 at 02:20 PM

avatar image Kenomica Jul 15 '14 at 05:57 PM

Thanks for the update - glad to hear it.

avatar image Kenomica Jul 17 '14 at 01:32 AM

With the release of the official 4.3 - I was very sad to see that this issue is still in existence.

the constrained object still drops to the ground as it did in the 4.3 preview (works perfectly in 4.2.1)

avatar image Jonathan Dorman STAFF Jul 17 '14 at 01:40 PM

It's still not working? That's odd...

I've got a record here saying that you edited your post saying that the issue was fixed, then edited it back. I assume that means it's not fixed after all?

I'm trying to reproduce your bug so that I can either find a workaround or more accurately report the bug (to get it fixed!) but I could use some more details about the situation. I can attach skeletal meshes to animating skeletal meshes without any problem in 4.3, which means there's something more complex involved.

avatar image Kenomica Jul 17 '14 at 11:06 PM

Yes, I thought it had fixed - but sadly as soon as I enabled physics simulation it didn't work - it just fell to the ground oddly.

Basically, I have a dinosaur character blueprint, the main skeletal mesh is the dinosaur. The tongue skeletal mesh is a child of the dinosaur, which I attach using sockets (either using a physics constraint or construction script "attach to" node) which worked perfectly in 4.2.1.

They both have physics assets.

The tongue is set as a physics body and simulated physics is on (as the effect I'm going for is a lolling tongue similar to a dog)

If I turn physics off, the tongue follows perfectly, as it has attached - but obviously it does not simulate physics.

If I turn physics on, the tongue drops to the floor.

Thanks for the reply, hope that's enough information to help you reproduce.

avatar image Jonathan Dorman STAFF Jul 22 '14 at 07:01 PM

Hey, sorry for the silence, I've been busy. Are you still having this problem?

avatar image Beaulamb Jul 22 '14 at 07:31 PM

Hi, sorry to bump into this thread but just wanted to say that I'm having this problem. It seems that whenever the character BP receives input from the player the physics asset just drops to the floor. I used a timeline in a separate BP to move a mesh with another physics mesh constrained to it and that all works fine.

avatar image Jonathan Dorman STAFF Jul 22 '14 at 07:41 PM

I think this might be a different problem - Kenomica isn't using any player input for his (adorable) dinosaur. It might be best to make another thread with your question - it'll be more visible and more people can look into it that way.

avatar image Kenomica Jul 23 '14 at 12:58 AM

No problem, I know you guys have a lot to do.

Yes, the problem still persists.

I've tried the construction script method, event graph and physics constraints. All work the same way. Tongue just drops to the floor.

I've also tried using parent sockets to place the tongue in the correct place, as well as having it placed at origin (having the blueprint snap it in to place on run or construction) - still the same. It just drops to the ground and the dinosaur continues to move forward.

Now, I tried changing the constraints to see if that had an issue and it caused a crash which may have corrupt my whole project (I REALLY hope not)

Question for that issue posted here: HERE

avatar image Jonathan Dorman STAFF Jul 23 '14 at 07:19 PM

I've got a guy at the office here working on a similar situation with a broken physics constraint. Trying to figure out if there's a relation between his situation and yours.

If you don't mind, can you maybe set up a keypress to attach the tongue during runtime? What my coworker is seeing is that the first time he applies an impulse to the constrained object, it falls to the ground. Every impulse after that works normally. Maybe if you can apply the constraint after it falls to the ground, it'll work?

avatar image Kenomica Jul 24 '14 at 05:04 AM

Sounds like a good place to start. Hopefully I can access my project and test it out. I'll let you know the results.

avatar image Beaulamb Jul 22 '14 at 07:43 PM

Ok cheers will do :)

avatar image acallado Aug 04 '14 at 03:37 PM

Looks like this issue is on 4.4 preview too: someone else can confirm?

avatar image Jonathan Dorman STAFF Aug 04 '14 at 03:58 PM

Hello, acallado.

Are you having the same problem as Kenomica? If so, please make a separate AnswerHub post and we'll try to get you sorted out. That may help us find the solution to Kenomica's issue as well.

avatar image acallado Aug 04 '14 at 04:17 PM

Hi, Jonathan.

I'm trying to confirm it myself here first, before I tie you guys up for nothing. Thanks for the prompt answer! Cheers

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, Kenomica.

We haven't heard from you in a while, so we're marking this post as resolved for tracking purposes. If this issue is still a problem, respond to this message and we can get back to work on it.

Thanks,

Jonathan

more ▼

answered Aug 20 '14 at 07:44 PM

avatar image Kenomica Nov 07 '14 at 05:42 PM

Hey, I appreciate the continued support and understand I was away for a while. I had computer issues which resulted in me losing the animations, rig, tongue etc - so I didn't get around to trying things again.

I've now re-rigged and re-animated the dinosaur and tongue - and I am now using 4.5.1 - sadly the same issue still occurs!

avatar image Jonathan Dorman STAFF Nov 07 '14 at 08:21 PM

Okay, let's just cut the middleman here. Can you send me a stripped-down version of the project with the mesh/animations/etc necessary to reproduce the error? Just upload it to google drive/dropbox/mega and privately send the link to me on the forums. We'll get to the bottom of this.

avatar image Kenomica Nov 11 '14 at 12:07 PM

Thank you. I'll send the link now, there will be a few blueprint link errors since I've migrated the problem meshes to a new project and deleted any unnecessary items.

avatar image Jonathan Dorman STAFF Nov 11 '14 at 03:49 PM

This implementation is a little kludgy, but it's progress at least. If you set 'Simulate Physics' for the blueprint's Tongue component to 'Off', and then, for the instance already in the level, set all of the tongue's bones except the first to Simulate Physics: On, you end up with the following state:

alt text

I'm still trying to find the cause of the errant behavior, but hopefully this workaround helps.

(If you don't want an image of your project on the AnswerHub, say so and I'll remove it from this post.)

dino_run_tongue.png (722.4 kB)
avatar image Kenomica Nov 12 '14 at 12:34 PM

Thank you for taking a look. I really appreciate your continued support.

I tried the workaround and it kind of works, but the tongue is no longer attached to the character when I do so.

However, and here's the strange part, I was just going through everything once more to make sure I'd not missed a step. In PHaT, I have all the bones except the first to "simulate" - and then once I gave up for the day I went to turn it back to static so during gameplay it doesn't fall off.

I turned simulate physics OFF in the blueprint for the tongue, hit play expecting the tongue to not move....and completely by accident, the opposite of what I was attempting happened...the tongue was working!

It seems the necessary mix is to have Simulate on the bones in PHaT and Physics OFF in the BP. I'm 99% sure I had that setup many, many times before so I have no idea why it suddenly worked!

avatar image Jonathan Dorman STAFF Nov 12 '14 at 02:26 PM

It's possible that when you tried it last - maybe back in 4.4 - it wasn't working correctly, and has since been fixed. I'm still investigating the original issue, because the tongue should never have teleported to the origin, but I'm thrilled to hear that we found a configuration that gets the desired effect.

avatar image Kenomica Nov 13 '14 at 03:30 AM

Thank you for all your help. I'm really pleased to have it finally as intended.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I've been seeing a similar issue lately I think, when trying to turn on simulation on a bone after animating a car door open. I've created a topic on it.

I'm going to test using a socket tomorrow. Attaching a seperate skeletal or static mash and animating then enabling physics.

With the bone method, the door would simulate fine if it was constrained to the root bone, but then would pin the car down if simulation was off. But then if I constrained to anything other than the root, it wouldn't pin down the car, but would fall off to the ground like stated above with the tounge. When simulation was turned back on.

I haven't tried to re-constrain after simulating pysics on my second test. Maybe that could work... But in any case, i should probably use sockets anyways to reduce bone count and since the car doors and whatnot could break off and not be permanently attached.

more ▼

answered Oct 27 '15 at 03:49 AM

avatar image

mLichy
1 1 4 3

avatar image Ben Halliday STAFF Oct 27 '15 at 01:45 PM

Hi mLichy,

We'll address the issue on your other post. This post is rather old, and we'd prefer to tackle your issue with fresh information. Thank you.

https://answers.unrealengine.com/questions/323096/vehicle-part-animationphysics-bug.html

avatar image mLichy Oct 27 '15 at 01:54 PM

Ok, thank you! Sounds good!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question