x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Clothing tool ignores Physic asset

alt text

I'm currently using 4.17 version of the engine, and my cloth goes through the mesh, no matter how you put collisions in the physic asset. I've tried recreate it several times. It has 4 capsules for legs and 1 for the chest, there are no boxes. I've tried play with parameters, mostly with Collision Thickness, but the cloth doesn't react at all to the body moving. I've exported the mesh from blender. Any help is appreciated, thanks.

Product Version: Not Selected
Tags:
clothcollisions.png (515.7 kB)
more ▼

asked Aug 16 '17 at 11:15 AM in Bug Reports

avatar image

Gamberana
26 1 2 6

avatar image Kenma Sep 08 '17 at 11:06 PM

I would like to have this answered as well. I am attempting to use the built in clothing tool, and it completely ignores the physics asset that I created in engine. (I know the tool is still experimental.)

avatar image Shempii Sep 11 '17 at 09:39 PM

I'm having the same issue. In my case, I'm trying to use the cloth too on a mesh that is SEPARATE from my character. I don't actually even know if this is supported yet but I'm hoping that it is because I have customization in my game.

I know this tool is experimental but this seems like a pretty common use case.

avatar image Gamberana Sep 12 '17 at 10:28 AM

if the cloth has the same weights of the character it should work, anyway i didn't find a solution yet about this, collisions still don't work

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

now there's an answer in another thread https://answers.unrealengine.com/questions/667930/clothing-tool-collision-not-working.html that apparently can solve the issue. The main problem is probably the scale of the armature in the upper left corner that in my image is "approx size:650x425x1548" and it must be something like 200x200x200 to work, you can read the full answer in the link above, hope this helps.

more ▼

answered Sep 14 '17 at 04:10 AM

avatar image

Gamberana
26 1 2 6

avatar image KingVario Dec 15 '17 at 04:10 PM

I did export with 1x1x1x scale but the engine still shows uneven aproximate size, because its calculating it based on bounds not based on what it imported. I tried exporting/importing various ways its impossible to get like 200x200x200x when the character is 2 meters tall 1 meter wide and 0.5m width, the engine will just calculate based on that.

we need the real solution to this problem

avatar image henbull Dec 18 '17 at 04:07 AM

Has anyone had any luck figuring this out? I'm in the same situation. Not having issues with re-scaling after applying cloth, it just won't collide.

avatar image KingVario Dec 27 '17 at 10:26 PM

Yeah i did, just like Gamberana said, you need to make sure your scene settings are set to 0.01, export with default options, import in unreal with default options. At first my mesh was too small 1x1x3 i could barely see it in inspector, then i went to blender and left scene setting to 0.01 and scaled my mesh and armature by 100 and applied everything then rexport/reimport (deleting old ones in UE4 first) then i setup my physics asset > create my cloth > paint weights> apply cloth and it works now. It really depends on what export/import settings you use. By the way my mesh has scale 1x1x1 in blender with dimensions 1.17m,40.7cm, 2.06m, but in unreal engine it shows 81x234x319 so i have no clue on what is happening there but the collision works.

avatar image Gamberana Dec 22 '17 at 08:33 AM

when you export the mesh it must be in centimeters (0.01), or that approx size is going to be too big

avatar image muh.yusup Jan 21 '19 at 01:33 PM

OMG FIX.. THANKS YOUUUUUU U just Apply scaling 1.1.1 your bone in Blender...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question