x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Hosting not works only joining session in Steam online multiplayer

I ran into a weird bug lately, and after searching answerhub and other forums it seems that it is quite a rare issue since I couldn't find any mention of it. I downloaded the Blueprint Multiplayer tutorial project https://www.youtube.com/playlist?list=PLZlv_N0_O1gYqSlbGQVKsRg6fpxWndZqZ and built a version just to see how it works (no modifications whatsoever). It seems that some people can only Host a game, while others are able to Host and to Join as well. With some friends we were able to connect to each other a couple times, but with others it is impossible (if both of us can only Host a game). We always had the same result with a person, so if "User A" could only Host that was always the case, if "User B" could Host and Join as well, that worked like that all the time. Every player had Steam running of course while testing, and we are not in regions where it should cause a problem (the testers were from the same country with the results above). Tried with 4.11 and 4.15. We have tried to open the ports UE4 using, but it didn't work and even if it would it wouldn't be a real solution since I couldn't release a game if players need to open ports manually to play. I assume that the tutorial project should work for everyone in both ways, so it really a mystery what could be the issue. It is really a pain, since a working Steam multiplayer is the only feature left to release a game I made.

Product Version: UE 4.15
Tags:
more ▼

asked Aug 16 '17 at 06:13 PM in Blueprint Scripting

avatar image

Airner
33 11 16 24

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question