x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[daydream] Daydream Laser behavior broken in 4.17

I'm trying to upgrade my project to Epics 4.17 binary and noticed the laser beam is broken in 4.17

The laser appears just as the small plane mesh and is not extended anymore. Picture is easier to explain:

daydreamlaser.png

It does not matter what distance I set for it, it always just has this little bit sticking out. It can be reproduced on a totally blank project. Also attaching here: daydreamcontrollertest417.zip

Any ideas how to fix? It did not behave this was in 4.16 :(

Product Version: UE 4.17
Tags:
more ▼

asked Aug 17 '17 at 07:58 AM in VR

avatar image

aussieburger
1.5k 43 176 75

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thanks to @jasonh2013 found the issue is the material packaged with the 4.17 is incorrect for the Binary. Using the material from here fixes the issue:

https://github.com/googlevr-unreal/UnrealEngine/blob/4.16-googlevr/Engine/Plugins/Runtime/GoogleVR/GoogleVRController/Content/LaserPlaneMaterial.uasset

It would be great if Epic could fix this in the 4.17 branch!?!

more ▼

answered Aug 23 '17 at 06:22 PM

avatar image

aussieburger
1.5k 43 176 75

avatar image RobMilliken Feb 27 '18 at 06:39 AM

So wish I could get that asset. That repo no longer exists. Not sure if this was ever fixed for later versions.

avatar image aussieburger Feb 27 '18 at 08:05 PM

Repo does still exist - you need to be logged in with your github account that is connected with your epic account first ;)

ie: you need to be able to see Epics github: https://github.com/EpicGames/UnrealEngine

avatar image RobMilliken Feb 28 '18 at 08:01 AM

Aha! There is a not so secret handshake! Okay. I did this but the LaserPlaneMaterial.uasset appears to be identical to the one in 4.18 - so I guess this was "fixed" by 4.18.

My issues - and what brought me here in the first place is the fact that though the reticle appears okay and the controller itself moves/operates as expected, the cool laser like thing that is supposed to project doesn't at all (not even a little bit like the OP). It does show up in the editor preview:alt text

If I make the tag none in controller, I get a cool Scott Summers like thing where two off center lasers comes out of my point of view. (I write this in part to illustrate that the material itself appears to work on my device.) Cool but not desired behavior - I would think it should come out of the controller and go in the direction of the reticle. Matching tags between GoogleVRMotionController and GoogleVRLaserVisual create a working reticle but no laser in sight.

I package with Android/ATC and use a Pixel 2 XL device to test. Further pertinent settings: alt text


alt text

Any ideas?

avatar image aussieburger Mar 01 '18 at 08:37 AM

Hmmm not really your settings look correct. Best bet would be to ask the Google devs over at this link to see if they can see what is amiss:

https://github.com/googlevr-unreal/UnrealEngine/issues

avatar image RobMilliken Mar 02 '18 at 04:46 AM

Hey Aussie -

Thanks for the reply! Yeah, it confounds me. I have been relegated to just use a small thin cylinder for now and make a texture for it later. While doing this I noticed my Datasmith plugin was left on - which had created issues for mobile in the past. I removed the plugin whereby the editor restarts and now get a crash every time I restart the project. I have sent the details to Epic. I can't win though. Thankfully I keep a template for VR setup as I am merely testing this feature out for now. The simple long thin cylinder as a "laser pointer" seems to be my solution for now as it worked before I lost the project. If I find a better solution, I'll post it here.

avatar image RobMilliken Mar 03 '18 at 09:26 AM

Aussieburger and lurkers....

Okay, figured it out and maybe you'll want to hit my head over a frying pan like I feel like doing right now. I had been using version 4.19 preview 5 because it appears to solve an issue with the web browser widget in Android I had an issue with in 4.18. Why do I bring this up? Because when I started a new project I didn't think but to start with the "better" 4.19 preview 5 - which from everything I've seen so far appears to BREAK the laser thing for some unknown reason to me. I write this now because I started over completely in 4.18 and it worked the FIRST time I tried. So yeah, I know not to use preview versions like they are final versions. Now I know to REALLY follow that rule. It is interesting though to not that 4.19 preview 5's behavior does as it does and should be revisited if on final release it is still doing these troubling things - in this case not showing the laser at all. Likely though some code was regressed to not break other things and will be functional again on final release. Anyway, thank everyone for the look and trying to help out. Maybe this'll help someone trying a preview version not make the same mistake I made.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question