x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Adding navmesh results in crash

When attempting to add a navmesh to my level for AI navigation, my editor crashes with "GetWorld()->GetNavigationSystem() != NULL"

I understand this is using the preview build, but I attempted to add a navmesh using 4.2.1, and I was greeted with the same crash.

This does not happen on other levels, and is not related to any actor in specific, as I've deleted everything in the scene, and tried to add a navmesh with the same result. Interestingly, when I delete everything in my scene, my level is still over 8mb.

!Id:87f4c8efef53b1d0dd0389be30a6633f

Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: GetWorld()->GetNavigationSystem() != NULL [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.3\Engine\Source\Runtime\Engine\Private\NavMeshBoundsVolume.cpp] [Line: 46]

KERNELBASE + 37901 bytes UE4Editor_Core + 3009475 bytes UE4Editor_Core + 1775818 bytes UE4Editor_Core + 1703552 bytes UE4Editor_Engine + 5526479 bytes UE4Editor_CoreUObject + 1104793 bytes UE4Editor_UnrealEd + 7320377 bytes UE4Editor_UnrealEd + 7585585 bytes UE4Editor_UnrealEd + 7318007 bytes UE4Editor_UnrealEd + 922436 bytes UE4Editor_UnrealEd + 622159 bytes UE4Editor_UnrealEd + 2694373 bytes UE4Editor_UnrealEd + 2755183 bytes UE4Editor_UnrealEd + 2749562 bytes UE4Editor_LevelEditor + 1712377 bytes UE4Editor_LevelEditor + 1761087 bytes UE4Editor_Slate + 636184 bytes UE4Editor_Slate + 586854 bytes UE4Editor_Core + 2986092 bytes UE4Editor_Core + 2919905 bytes UE4Editor_Core + 2990975 bytes UE4Editor_Core + 2908930 bytes user32 + 105425 bytes user32 + 104666 bytes UE4Editor_Core + 2991990 bytes UE4Editor!FEngineLoop::Tick() + 2990 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.3\engine\source\runtime\launch\private\launchengineloop.cpp:2061] UE4Editor!GuardedMain() + 476 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.3\engine\source\runtime\launch\private\launch.cpp:133] UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.3\engine\source\runtime\launch\private\windows\launchwindows.cpp:125] UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.3\engine\source\runtime\launch\private\windows\launchwindows.cpp:207] UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Product Version: Not Selected
Tags:
more ▼

asked Jul 15 '14 at 01:05 AM in Bug Reports

avatar image

Havoc
287 21 22 36

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you

more ▼

answered Oct 03 '14 at 03:00 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question