x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Far out particle emitter behavior

hi all,

im trying to follow the latest Cascade tutorials from mr.Parrish, but already at the beginning hit a solid wall. For some reason, the most default mat we created in the tutorial, used on a mesh typedata emitter results in this (it should look like small greyish bubbles, as on the video

weird squares

heres the screenshot of the material editor aswell. alt text

Im out of ideas, the only thing different I guess is that my version is still at 4.2 and maybe Zak uses 4.3 that has some other features.

cheers for any info

Product Version: Not Selected
Tags:
simplepart.jpg (34.8 kB)
mat.jpg (250.6 kB)
more ▼

asked Jul 15 '14 at 01:24 AM in Using UE4

avatar image

strahobrz
21 3 6 10

avatar image Jacky Jul 15 '14 at 01:38 AM

Which video is it exactly?

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

Hi Strahobrz -

Sorry misunderstanding your terminology with the particle systems. A Mesh emitter is what I thought you were dealing with, but for a default sprite particle system RimmyD is correct the material itself was your problem.

Here is what the default material should look like:

alt text

The Particle Color node will allow the Color Over Life default node to add color to you particles in Cascade as well as set their alpha (transparency) value.

Thank You

Eric Ketchum

defaultpart.jpg (154.3 kB)
more ▼

answered Jul 16 '14 at 08:27 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 256 733

avatar image strahobrz Jul 16 '14 at 11:19 PM

Eric,

thanks so much for having the patience with me. But like I said n one of the bottom comments, I already tried with the exact replication of the material in the video, and it produces the same effect. The material itself looks different to yours in the preview window. Check the picture for proof

alt text

matexample.jpg (367.4 kB)
(comments are locked)
10|2000 characters needed characters left

Hi strahobrz -

The default Mesh used in the Mesh Emitter is a Cube, which it looks like you are using with your material. This is causing your fade to be applied to each face of the cube in a way that you are not wanting. Change the Cube in the Mesh Data Type to the Material Sphere or Simple Sphere in the Content Browser. That should generate the look of a sphere like you have in the Material Editor.

Let me know if you are still having problems -

Eric Ketchum

more ▼

answered Jul 15 '14 at 03:59 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 256 733

avatar image strahobrz Jul 16 '14 at 12:58 AM

Eric thanks for the response.

The above behavior is the same even if I open a completely default particle setting and use a default material on it.alt text

no default mesh data type to change... At least with my basic knowledge ?

defaultpart.jpg (253.4 kB)
(comments are locked)
10|2000 characters needed characters left

I think you have gotten a bit off track and are trying to use the wrong material. The material you want is what he makes at about 2:03 in the video.

http://youtu.be/jBUF6at1s1o?t=2m6s

The one you are showing is a banded texture for use in a ribbon or beam. The confusion probably comes from viewing it on a sphere. change to viewing it on a plane or cube to see the actual texture.

alt text

capture.jpg (12.9 kB)
more ▼

answered Jul 16 '14 at 12:53 AM

avatar image

RimmyD
2.6k 98 15 96

avatar image strahobrz Jul 16 '14 at 01:17 AM

Rimmy, thanks for chiming in. Even with the basic mat, like done in the video with radial gradient exponential, this is what comes up in on default particle system

alt text

partmat.jpg (175.3 kB)
(comments are locked)
10|2000 characters needed characters left

Hi strahobrz -

For some reason I believe your Radial Gradient Material Function is incorrect. Can you open your Radial Gradient Material Function, double-click on the node in your material editor, and check it against the picture below:

alt text

Let me know if there are any discrepancies, also what version of teh engine are your using.

Thank You

Eric Ketchum

matfunction.jpg (399.6 kB)
more ▼

answered Jul 17 '14 at 01:23 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 256 733

avatar image strahobrz Jul 17 '14 at 02:56 PM

Eric, still using 4.2. And YES the gradient function was different to yours. I adjusted it accordingly and now the material seems to be working correctly.

the same issue remains though if I make a simple mat, with only particle color component, and connect the output and alpha to the opacity and emissive channels. I get squares instead of circly shapes. Is this normal, in the sense that particle materials have to be done differently ? (I havent proceeded through Zak's tutorial because I wanted to clear up the issues first so I may be asking wrong, trivial questions regarding particle mat creation)

again, thanks so much for helping me ! UE4 support rules

avatar image Jacky Jul 17 '14 at 03:03 PM

If you use only Particle color node and no gradient or an alpha texture for opacity then it is normal to get square shapes. Since there is no information(gradient or black&white texture) to tell it what shape the opacity should be, it takes the particle sprite's shape. This applies to translucent and masked materials in general though, not just particles.

avatar image Lovecraft_K ♦♦ STAFF Jul 17 '14 at 03:52 PM

Hey strahobrz -

Jacky is correct. But I do want to clarify what exactly is being generated in the Particle System. A default emitter, Sprite emitter, is generating planes. You can see this by changing the view mode in Cascade to Wireframe and all that is generated is planes. So unless, as Jacky says, an alpha is generated you are adding color to the whole plane and alpha fading the whole frame.

alt text

Thank You

Eric Ketchum

defaultpart.jpg (69.7 kB)
avatar image strahobrz Jul 17 '14 at 10:56 PM

ahhhh awesome !!! This clears up many things I wanted to ask....

thanks so much Jacky and Eric. Hopefully this puts an end to my particle enigma !

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question