x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UE 4.16.3 and 4.17.1 - Rotation in Array of Transforms Bugged

Well, i don't know other way of reporting a bug, and after some google search and forum search i saw no other reporting or saying anything about this... so i'm putting this in here.

The Bug/Problem i found is with the "Array of transforms" acting weird and giving imprecise values and changing randomly to other values by clicking in and out of the input box, and by how i see it it's completely broken and unusable...

Additional info:

Where it happens-> In the Blueprints Editting Window.

How to reproduce->

  1. Create an empty project.

  2. Open it and then in the content browser(or anywhere in the project, this doesn't matter) create a new empy Blueprint of any class(all my tests was with simple actor).

  3. Open the Blueprint and in the left panel create a new Variable of "Transform" and then change the variable type to "Array".

  4. Compile so the array can manually populated.

  5. Select the variable and in the right panel click the cross to add a new element to the array.

  6. Now try to put 90 degrees in all the rotation axes (XYZ), here is where everything bugs as f**k.

I uploaded a video in youtube demostrating everything in case i was not clear enough. The first part of the video is showing the bug in the v4.16.3 with subtitles explaining everything BE SURE TO HAVE THEM ENABLED, and the second part is showing the same process without any explanations but in the v4.17.1 with the same result.

Here is the link: Link to the video

I recommend skipping the start because the video is very long, so skip all the shit and go directly to Min 4:14 or to Min 6:30 for the test with the HISM

PS: I'm not completely sure, but i remember seeing this problem with the transform like 1 or 2 years ago when i started using UE4 and i did not know much about how to use it... but i can't believe this has passed unnoticed for such long time... :S

Product Version: UE 4.17
Tags:
more ▼

asked Aug 28 '17 at 01:17 PM in Bug Reports

avatar image

sgghostrider
6 1 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey sgghostrider:

It looks like you are running into an issue that has been noted in our database. Until the issue is resolved, feel free to keep track of it by following the link below:

https://issues.unrealengine.com/issue/UE-4459

If there is anything else that I can help you with, please let me know.

Sincerely, Natalia

more ▼

answered Aug 31 '17 at 06:57 PM

avatar image

Natalia Q ♦♦ STAFF
565 2 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question