x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.17 - umap failed to save

Since I moved to 4.17.1 from 4.16.3, most of the time when I save a map, I get this error: alt text

I press "Continue" and it keeps saving. I tried on empty projects, empty maps - the same result.

Product Version: UE 4.17
Tags:
more ▼

asked Aug 18 '17 at 04:18 PM in Bug Reports

avatar image

Flash7
839 9 17 29

avatar image Harcarik Aug 18 '17 at 08:10 PM

I have exactly same problem. At first i suspected that backup software (crashplan) may be a culprit but apparently it's not. Problem persist even after i suspend the backup.

avatar image k00m Aug 19 '17 at 07:16 PM

Same for me, after have update to 4.17 and 4.17.1 I get the save umap error. It's not the same topic but I get a other problem about the engine procress update in 4.17.1. At around every 1min I get a strange lag on my physics simulation, I never get this lag from 4.16.3.

avatar image sgghostrider Aug 25 '17 at 07:42 PM

Yep, same here, at first i thought it was my project because i updated recently to 4.17.1 version, and today i upgraded my project to that version too, and when i tried to save after spawned a blueprint that i was working on the whole day it started to show me that message that says i can't save, and i was like "wtf?! i can't save?!!" but it seems that it's saving anyways, but the message is very annoying because each time i want to save i have to do 2 clicks more than usual... and even more annoying when there are a blueprint with a HISM component with a constructor script because the asterisk in the tab don't disappear after i save... -_-

avatar image GameMaster79 Aug 27 '17 at 07:07 PM

Yeah, same problem here as well. I'm also getting some crashes when I go to play in the editor for the second time or compile certain blueprints.

avatar image llll Sabre llll Aug 31 '17 at 02:19 PM

Same problem here

avatar image Thomas G ♦♦ STAFF Sep 01 '17 at 05:58 PM

Hello Flash,

I was unable to reproduce your issue on our end. I have a couple of questions to help narrow down the issue you are experiencing.

  1. Are you able to reproduce this issue in a new project?

  2. If so, could you provide a detailed list of steps so that I can reproduce this issue on our end?

Thanks!

avatar image Flash7 Sep 02 '17 at 02:35 AM

Thomas, 1. Yes, it is reproducible in the new project. BUT, there are times when it saves normally, and there are times when it fails. It is random. It can save normally 10 times and fail on 11th. Sometimes it fails all the time including auto saves. 2. Just create a new project, try to save.

It is also reproduced by every team member in our company. It happens only in 4.17

avatar image RVillani Sep 06 '17 at 09:33 AM

Thomas, it seems to be related to the Blueprint setting Save on Compile. If I set it to On Success Only I see the bug. If I leave it as Never, it seems to solve it.

avatar image k00m Sep 06 '17 at 08:39 PM

Yes set it to never seen to fix the auto save error message for me too.

avatar image Harcarik Sep 06 '17 at 05:54 PM

Strangely enough, i created new project to test the problem Thomas asked us ands ince then i had zero occureneces of the bug. I just created new project twice, with and without starter content, moved few actors, saved, compiled static light, closed, restarted projects, launcher. Nothing since then. New project was topdown BP template.

avatar image Flash7 Sep 06 '17 at 06:36 PM

Right, it does not happen all the time. My project was created from 3rd person template in 4.17.1 and I have auto save on compile enabled and auto save every 10 min. I have from time to time through out the day that error.

avatar image Harcarik Sep 07 '17 at 04:08 PM

I spoke too soon. Because of this bug I am still using 4.16. After the test i performed earlier, I thought the bug is gone and I upgraded to 4.17 But i was wrong. Now it is happening almost every time i save. Mostly map file, other file type are affected less frequently. I am getting sense it is based on file size. Map is around 70Mb, Bp i am working on are are way smaller.

Additional info that may/may not be relevant. I tried to upgrade by launching 4.17 and opening 4.16project where I would be asked if I wanted to create copy of the project and that would be upgraded. But this time new bug appeared. Apparently there is not enough disk space. There is more than ~100Gb of free space vs project folder's 25Gb. So i copied folder in the explorer and ask Launcher to upgrade 'In Place' and that worked. And now the Save bug happens all the time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

it is possibly fixed in 4.17.2

https://issues.unrealengine.com/issue/UE-48672

more ▼

answered Sep 15 '17 at 03:52 PM

avatar image

Flash7
839 9 17 29

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You get the same message when you opened the project 2 times. But other than that, I sadly never got it :|

more ▼

answered Aug 25 '17 at 08:56 PM

avatar image

Ninjin
4.1k 88 38 152

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

happens some times for me when i have 2 versions running of the same map.

more ▼

answered Jun 21 '18 at 04:25 AM

avatar image

OGSWG
6 2

avatar image ReclusiveRychu Aug 14 '18 at 05:22 PM

This was my problem, haha I had two versions running and didn't even know it. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You'll see this also when you simply don't have file permission.

I just copied a project from my laptop where I use a different user. It took me a while to figure out because it appears to sometimes to work (if you run the project under admin) and sometimes not and only on the files I copied.

more ▼

answered Jan 05 '19 at 03:25 PM

avatar image

cepakst
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question