x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Child widget buttons not working within switcher

I have been learning how to use UE4 and after following Titanic Games RPG tutorial series have begun adding to/rebuilding some of the systems he sets up. In this case I want to create a single window that opens with tabs at the top to switch between various elements the player can use (inventory/skill tree/journal etc.) It seems that the widget switcher is just what I need.

I have 2 widgets, UI_Inventory that populates a uniform grid with another widget (UI_Inventoryslot) which is basically a button with a variable that on creation holds the item info passed to it from the UI_Inventory and on clicked enables a use/drop button in the UI_Inventory and sends the item info back. The other is UI_Equipment and works in a similar way, it creates child widgets from UI_Equipmentslot which hold the item info and on clicked simply clear themselves and pass the item info that was there on.

The Problem, These two widgets were built so that they could be added/removed from the screen separately with their own buttons and work perfectly well as such. I have created a new widget with a panel at the top for the buttons and another below it with a switcher but when I add my UI_Inventory to the switcher it shows up fine and the item buttons within update as they should but when I click them they do nothing, they show that they are being clicked (the tint is different on hovered and on clicked) but the functions aren't firing (the use button doesn't get enabled) so I cannot use them. same for the equipment the buttons show I'm clicking but don't actually do anything.

I'm probably missing something simple here but not sure what.

Product Version: UE 4.16
Tags:
more ▼

asked Aug 19 '17 at 09:40 AM in Blueprint Scripting

avatar image

Belarin
11 1 1

avatar image Belarin Aug 19 '17 at 01:39 PM

Update: managed to get this working by passing a few references down the chain of widgets, probably not the best solution in the long run but it's working for now. if anyone knows a better solution please let me know.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question