x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot create c++ project "Hexadecimal value 0x00 is an invalid character"

An error occurred while trying to generate project files.

Running C:/Program Files/Epic Games/UE_4.16/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="C:/Users/DarkK/Documents/Unreal Projects/PaperZD/PaperZD.uproject" -game -rocket -progress '.', hexadecimal value 0x00, is an invalid character. Line 1, position 1.

Happens with 4.16 and 4.17

Product Version: UE 4.16
Tags:
more ▼

asked Aug 22 '17 at 06:14 AM in Bug Reports

avatar image

HeavyBullets
277 11 19 32

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Guys, I opened the source code project for UnrealBuildTool and debugged that line of code

for some reason:

...AppData\Roaming\Unreal Engine\UnrealBuildTool\BuildConfiguration.xml

Had only NULL characters written (as illustrated by notepad++), removing this file fixed the issue

more ▼

answered Aug 22 '17 at 06:23 AM

avatar image

HeavyBullets
277 11 19 32

avatar image Davis3D Jun 29 '18 at 05:33 AM

Hi, I'm having the same issue. I have tried everything and even reinstalled windows with no fix. Would you be able to explain how you fixed it? What exact file did you open and what did you modify?

avatar image HeavyBullets Jul 04 '18 at 07:01 PM

It was the BuildConfiguration.xml file from unreal engine AppData... had null characters for some reason (they are visible in editors like Notepad++).. removing that file fixed the issue

Crazy week, sorry for not answering

avatar image Davis3D Jul 04 '18 at 11:43 PM

I might add, that the solution could be the same but also in the My Documents/Unreal Engine folder. BuildConfiguration.xml is sometimes in there as well, and if it has nothing inside the file then UE4 will give you the same error. It seems that if the file exists in My Documents, UE4 references it instead of the usual one.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question