x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Distance field AO: AMD Driver crash when changing Skylight to Movable

Hello,

I experience a driver crash when I enable distance field AO, load "StarterMap" (of a freshly created "Third Person Code" Project without any code changes), place a skylight and change its mobility type to Movable (once I click on Movable it crashes). The driver crash doesn't happen when distance field AO is disabled. I get the typical "Display driver has stopped responding and has recovered" popup and a message box showing "Video driver crashed and was reset! Make sure your video drivers...".

I am using the latest 4.3 source code (Jul 14, 2014) and the required+optional "4.3.0-preview" packages provided on the release page on github.

My GPU is a Saphire R9 290 Tri-X OC. I tried the latest AMD drivers (14.4 and 14.7 RC) but it didn't solve the problem. My OS is Windows 8.1 Pro x64.

Log file: http://bit.ly/1oBx8r6

DxDiag file: http://bit.ly/1mUURFm

Update 1:

I tried to find an actor which might cause the problem. After trying many combinations I found that actor "P_Sparks_Blueprint" might have something to do with it. If I open "StarterMap" and delete "P_Sparks_Blueprint" the driver crash still occurs. However, if I open "StarterMap", delete "P_Sparks_Blueprint", save the map to a new file, restart the editor (it doesn't seem to be enough to just reload the map), and open the saved map the problem seems to be gone. I am not really sure if the particle effect is the exact source of the problem, it might be a coincidence.

Product Version: Not Selected
Tags:
more ▼

asked Jul 15 '14 at 10:33 PM in Bug Reports

avatar image

KlausT
123 9 11 11

avatar image Alexander Paschall ♦♦ EPIC Jul 16 '14 at 04:05 PM

Thank you for your report. We have assigned this issue to a member of our support staff, and they will begin investigation as soon as possible. If we are unable to reproduce the issue, or we need additional information, our staff member will comment here with additional questions. Otherwise, we will post an ‘Answer’ once we have logged the issue in our bug database or we have a solution for it.

In the meantime, please be sure to review our suggestions for how to report a bug, and feel free to edit your post if you have additional information to provide. https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

I would like to request that you include your DxDiag, as this may be a hardware related error.

Thank you.

avatar image [Epic] Gribbs ♦♦ STAFF Jul 17 '14 at 04:14 PM

Howdy KlausT,

I was looking into your issue and I believe that you have the same issue as another user. The post can be found here: https://answers.unrealengine.com/questions/69182/changing-distance-field-resolution-scale-of-a-mesh.html. I have recreated the issue and I am currently waiting for a it of feedback before I write up a TTP of the issue. If it is not the same, please do let me know.

Thanks and have a great day!

avatar image KlausT Jul 17 '14 at 10:20 PM

I can't reproduce the problem described in the post.

avatar image [Epic] Gribbs ♦♦ STAFF Jul 18 '14 at 02:41 PM

Hey KlausT,

I wanted to confirm with you that the issue is not occurring any longer before I close this thread. I have been unsuccessful with any reproduction of the issue when I follow the repro steps that you have provided. If the issue is still occurring, please let me know so that I may investigate the issue further.

Thanks!

avatar image KlausT Jul 19 '14 at 12:31 AM

"I wanted to confirm with you that the issue is not occurring any longer"

It has been fixed? I created another few test projects and this time the crash didn't occur. However, in my old debug project the problem is still there. I tried the skylight in a few projects from the marketplace and didn't experience any issues. I hope the crash is limited to my old test project and won't occur any longer in new projects.

avatar image KlausT Jul 19 '14 at 03:08 AM

Ouch, I am stupid! I forgot to enable distance field AO in the new projects. Of course the crash persists in the map "StarterMap". In projects like ShooterGame or CouchKnights everything works fine, even with distance field AO enabled.

avatar image Midnight640 Jul 21 '14 at 12:15 PM

I also get a driver crash

avatar image [Epic] Gribbs ♦♦ STAFF Jul 22 '14 at 02:07 PM

Howdy Midnight640,

Could you send us your DXdiag? This will help us further investigate what we think the issue could be.

Thanks!

avatar image [Epic] Gribbs ♦♦ STAFF Jul 22 '14 at 02:11 PM

Never mind Midnight640,

I see that you have it listed in this post: https://answers.unrealengine.com/questions/72121/class-array-breaks-shipping-build-43.html

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

A fix for one GPU hang caused by DFAO is now in 4.5, hopefully it is the only GPU hang.

more ▼

answered Oct 04 '14 at 12:29 AM

avatar image

DanielW STAFF
1.9k 31 10 71

avatar image KlausT Oct 04 '14 at 03:51 AM

Currently I am using a GTX 970 and setting the skylight to movable works but after a while my screen freezes and I get the usual driver reset message. So yeah, I hope this one got fixed in 4.5. However, on my old R9 290 the driver reset occurs immediately without the freeze so I am not sure whether this is the same problem.

avatar image [Epic] Gribbs ♦♦ STAFF Oct 06 '14 at 07:26 PM

Howdy KlausT,

Thank you for your feedback. If you could, once 4.5 is release, reopen this issue so that we may further investigate if the driver crash is still occurring.

Thanks and have a great day!

(comments are locked)
10|2000 characters needed characters left

Hey KlausT,

Thank you again for your bug report. We had a fellow developer also crash when testing out Ambient Occlusion. I have entered the bug into our system database so that it may be fixed in a future release.

Thanks again and have a great day!

more ▼

answered Jul 22 '14 at 05:41 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.9k 292 13 76

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question