x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Print Node Doesn't Print to Screen on Begin Play or Construct events

Hi,

New to Unreal. Is there something I need to do to get the Print node to display text to the screen on BeginPlay or the Construct event?

I've tried a Delay node and increasing the visibility time on the Print node but this hasn't worked.

Thanks,

Product Version: UE 4.17
Tags:
more ▼

asked Aug 22 '17 at 05:44 PM in Blueprint Scripting

avatar image

0x6c6565
23 3 8 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Is this for a UI element? Widgets have Construct "Events".

I don't think print screen works in the Construct Function. It should work on BeginPlay, when the item is created in the game. Make sure the item is in the level, or is being spawned.

more ▼

answered Aug 22 '17 at 07:07 PM

avatar image

BenVlodgi
2.1k 38 17 52

avatar image 0x6c6565 Aug 23 '17 at 04:04 PM

I've tried this in the FPS character (BeginPlay) and in a UMG widget (Construct). I don't see anywhere in the documentation that remarks whether it will work on construct or not. Where did you find this, please? In the first person character I'm clueless as to why it's not printing. I'm currently running build 4.17 and I just made a quick sample project and the same thing is happening.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question