Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android fails for unknown reason

Hello everyone. A week back I decided to learn how to develop mobile games in UE4. I read the documentation and I watched various videos, however I keep having problems that don't make sense to me. So, what I have done is:

  1. I installed UE4.17

  2. I installed Android from UE4.17 directory (tried both 1R6 and 1R6u1 with all SDKs checked)

  3. I converted my project for Android (I have used both the 2D side scroller and an empty project)

  4. I set up the Android SDK paths

  5. I made sure Windows values are correct

  6. I enabled Dev Mode with USB debuging and USB install on two mobile devices (Xiaomi Redmi Note 4, Samsung Galaxy Core) - They both show up properly on CMD, however there are occasions where they are not displayed in the UE Editor when the Android SDK paths are set. If left blank the devices pop back up.

  7. I tried to launch both projects on both devices and nothing

The Xiaomi's Security app seems to be blocking the launch, it shows me a notification about blocking a USB install attempt and turns Dev mode off. I managed to launch the project and install the app via USB on Samsung Galaxy Core, but the game crashes. The empty project opens, the placeholder Unreal logo is displayed, then the screen goes black, the game exits and I get a message saying "The app has stopped working for an unknown reason". The 2D scroller tries to play when pressed but I get the same message after a couple of seconds with the game not launching at all. The UE Editor is also run with admin privileges. I have also tried the Project Launcher where I experimented with all available options (ATC, ETC1, Default, Multi, Android). It doesn't make sense to be so difficult. I must be missing something. Any help is appreciated. Thank you in advance!

Product Version: UE 4.17
more ▼

asked Aug 23 '17 at 11:36 AM in Using UE4

avatar image

13 1 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

So, I uninstalled Android Works, re-installed them from the UE4.16 directory and made the project again in UE4.16. Everything runs like a charm for some reason. The issue remains on 4.17

more ▼

answered Aug 25 '17 at 03:23 PM

avatar image

13 1 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question