x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Sample project stuck on Splash - Unreal engine 4.17.1

Hey,

I've been having an issue attempting to deploy a project (empty/sample projects, doesn't matter which) to an iOS device through Launch -> Project Launcher and selecting the connected iOS device. I've tried an iPhone 5SE, iPhone 7 and iPad (all running iOS 10 and up) with the same issue, so I don't think it's an ARM64/ARMV7 issue.

The problem is that while the project builds, signs and deploys nicely, the app gets stuck on the Splash screen and doesn't move further. In the logs, there aren't any errors mentioned, the only thing I can single out is this warning, which occurs after successful deployment and looks like the app is failing to connect to the dedicated server for some reason:

2017.08.24-00.14.44:495][ 0]LogFileServer: Display: Unreal Network File Server is ready for client connections on 0.0.0.0:41899!

[2017.08.24-00.14.44:495][ 0]LogFileServer: Warning: Unreal Network Http File Server starting up...

[2017.08.24-00.14.44:498][ 0]LogFileServer: Display: Unreal Network File Http Server is ready for client connections on port 41898

[2017.08.24-00.14.44:498][ 0]LogCookCommandlet: Display: GC...

[2017.08.24-00.15.22:672][ 0]LogFileServer: Display: Client Client For connected.

[2017.08.24-00.15.22:672][ 0]LogCook: Display: Connection received of version local version //UE4/Release-4.17 3573198

[2017.08.24-00.15.22:672][ 0]LogCook: Warning: Connection tried to connect with incompatable version

I did manage to get the sample projects deployed without issue through file -> package and manually installing the resulting IPA through iTunes, so the project configuration should be OK. Following the packaging steps, the app runs correctly but.. that cooking takes a hell of a lot of time, so I'd prefer not to do that every time I need to deploy it.

Note I have read some people with similar iOS problems throughout the last Unreal Engine versions. As of August 24 2017 I'm running the most up-to-date version of the Unreal Engine, as well as iOS and am working on MacOS (10.12.6, 2016 maxed out Macbook Pro). I have tried some of the solutions posted but either the source-code already has the mentioned fixes in my version, or the suggestions had no effect.

Do you have any suggestions on the cause or how to fix (or even debug, because other than looking at the log-files, I'm not sure how I can debug this) this issue? I'm running

Product Version: UE 4.17
Tags:
more ▼

asked Aug 24 '17 at 12:22 AM in Packaging & Deployment

avatar image

hawke84
0 1 3 4

avatar image Angel Tsvetkov Aug 25 '17 at 08:54 AM

Maybe something similar?: [bug] Stuck on 45% in Unreal Engine 4.17.0 https://answers.unrealengine.com/questions/679138/bug-stuck-on-45-in-unreal-engine-4170.html

avatar image hawke84 Aug 25 '17 at 11:44 PM

I doubt they're related. I've seen my problem with an empty scene and sample projects (not a thing modified). This guy seems to run into shader compilation issues; my bug occurs when the app is compiled, installed and running. It doesn't consume any heavy resources, it just... hangs.

My best guess is that something is going wrong with the connection to the dedicated server running on my Macbook, since packaging and installing the app outside of Unreal Engine works fine.

(added OS info to the bug)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question