x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.17 morph targets not showing - resolved!

Hi!

My morph targets on model X work perfectly when imported to 4.16. The same file of model X with the same morph targets and the same import settings in 4.17 don't work. They show up in the menu, but the sliders don't change anything on the mesh.

However, model Y that I had imported while the project was still in 4.16 do still work in the current 4.17 version.

Does anyone here have the same problem or a clue what I could do to fix this?

Thanks for reading! Thomas

PS. I've read the 4.17 update notes and I saw this: - "If you have empty morphtargets, they will go away with this change." Though I'm not sure it's what causes the problem, it might be worth mentioning.

Product Version: UE 4.17
Tags:
more ▼

asked Aug 24 '17 at 12:57 PM in Using UE4

avatar image

padewij
11 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Select the character's mesh in the content browser in Unreal. Right Click it, and select "Reimport." The morph targets and their sliders should now work.

If that did not work, try exporting the FBX file from Maya or Max as a 2017-2016 file instead of a 2018 file, and importing that file to Unreal.

Hope this helps.

more ▼

answered Aug 31 '17 at 07:56 PM

avatar image

JPenfield
6 1 1

avatar image padewij Sep 03 '17 at 09:43 AM

Wow, the reimporting did it. Can't believe I hadn't tried that yet lol. Thanks a lot!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It's still not working for us. Morph targets are broken for "additional meshes" since we updated to 4.17

more ▼

answered Sep 04 '17 at 11:51 AM

avatar image

JavierRamello
71 6 10 17

avatar image padewij Sep 04 '17 at 01:42 PM

So both ways mentioned above don't work for you? For me the reimporting fixed it. You might want to try to do that as cleanly as possible in a few ways, see if that can somehow help.

Otherwise for a temporary solution you could always import them in 4.16 and send them over to 4.17, although it's not preferable of course..

avatar image JavierRamello Sep 04 '17 at 06:13 PM

The morphs were imported in 4.16 and stopped working as soon as we updated to 4.17. It only fails with extra meshes. The main mesh morphs work good. (Both meshes have the same morphs with the same names)

avatar image padewij Sep 05 '17 at 05:49 PM

Sorry, but I don't know what could be wrong in that case. Maybe making another thread and explaining it in detail will help?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question